Bug 922481 - Review Request: nodejs-JSV - JSON Schema Validator
Summary: Review Request: nodejs-JSV - JSON Schema Validator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: T.C. Hollingsworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 922479
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-17 11:12 UTC by Tom Hughes
Modified: 2013-04-17 00:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-17 00:21:31 UTC
tchollingsworth: fedora-review+
pbabinca: fedora-cvs+


Attachments (Terms of Use)

Description Tom Hughes 2013-03-17 11:12:16 UTC
Spec URL: http://download.compton.nu/nodejs/nodejs-JSV.spec
SRPM URL: http://download.compton.nu/nodejs/nodejs-JSV-4.0.2-2.fc18.src.rpm
Fedora Account System Username: tomh

Description:
JSV is a JavaScript implementation of a extendable, fully compliant
JSON Schema validator with the following features:

* The fastest extendable JSON validator available!
* Complete implementation of all current JSON Schema draft revisions.
* Supports creating individual environments (sandboxes) that validate
  using a particular schema specification.
* Provides an intuitive API for creating new validating schema
  attributes, or whole new custom schema schemas.
* Supports self, full and described by hyper links.
* Validates itself, and is bootstrapped from the JSON Schema schemas.
* Includes over 1100 unit tests for testing all parts of the specifications.
* Works in all ECMAScript 3 environments, including all web browsers
  and Node.js.
* Licensed under the FreeBSD License, a very open license.

Comment 1 T.C. Hollingsworth 2013-04-05 21:49:25 UTC
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed

Status: APPROVED

===== Things to Consider ====

[ ]: Consider asking upstream to ship a seperate LICENSE file.

     However, since the license is included with the JS source in the package
	 the conditions of the MIT are satisfied, so this is not a blocker.

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[-]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "MIT/X11 (BSD like)", "Unknown or generated". 2 files have unknown
     license. Detailed output of licensecheck in
     /home/fedora/patches/FedoraReview/922481-nodejs-JSV/licensecheck.txt
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[-]: Large documentation must go in a -doc subpackage.
[x]: Packages must not store files under /srv, /opt or /usr/local
	 
Node.js:
[x]: Follows the Node.js Naming Guidelines
[x]: BuildRequires: nodejs-devel
[x]: Uses %nodejs_sitelib or %nodejs_sitearch where appropriate
[x]: Uses tarball from the npm registry
[x]: Installs only appropriate files in %{nodejs_sitelib}
[x]: Dependency versions are patched as necessary
[x]: Bundled modules removed in %prep

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[!]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
[!]: SourceX / PatchY prefixed with %{name}.
     Note: Source0 (JSV-4.0.2.tgz)
[x]: SourceX is a working URL.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.
[-]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
  

Rpmlint
-------
Checking: nodejs-JSV-4.0.2-2.fc20.noarch.rpm
          nodejs-JSV-4.0.2-2.fc20.src.rpm
nodejs-JSV.noarch: W: spelling-error %description -l en_US validator -> lavatorial
nodejs-JSV.noarch: W: spelling-error %description -l en_US schemas -> schema, sachems, schemes
nodejs-JSV.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
nodejs-JSV.noarch: W: only-non-binary-in-usr-lib
nodejs-JSV.noarch: W: dangling-symlink /usr/lib/node_modules/JSV/node_modules/uri-js /usr/lib/node_modules/uri-js
nodejs-JSV.src: W: spelling-error %description -l en_US validator -> lavatorial
nodejs-JSV.src: W: spelling-error %description -l en_US schemas -> schema, sachems, schemes
nodejs-JSV.src: W: spelling-error %description -l en_US js -> dis, ks, j
2 packages and 0 specfiles checked; 0 errors, 8 warnings.

OK


Rpmlint (installed packages)
----------------------------
# rpmlint nodejs-JSV
nodejs-JSV.noarch: W: spelling-error %description -l en_US validator -> lavatorial
nodejs-JSV.noarch: W: spelling-error %description -l en_US schemas -> schema, sachems, schemes
nodejs-JSV.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
nodejs-JSV.noarch: W: only-non-binary-in-usr-lib
nodejs-JSV.noarch: W: dangling-symlink /usr/lib/node_modules/JSV/node_modules/uri-js /usr/lib/node_modules/uri-js
1 packages and 0 specfiles checked; 0 errors, 5 warnings.
# echo 'rpmlint-done:'

OK

Requires
--------
nodejs-JSV-4.0.2-2.fc20.noarch.rpm (rpmlib, GLIBC filtered):
    
    nodejs(engine)
    npm(uri-js) < 1.5
    npm(uri-js) >= 1.4.2

OK

Provides
--------
nodejs-JSV-4.0.2-2.fc20.noarch.rpm:
    
    nodejs-JSV = 4.0.2-2.fc20
    npm(JSV) = 4.0.2

OK

MD5-sum check
-------------
http://registry.npmjs.org/JSV/-/JSV-4.0.2.tgz :
  CHECKSUM(SHA256) this package     : 5eadb7efc8c195371b0417f5870913226abba49c51cbc6dd4bdc569ae0b3117d
  CHECKSUM(SHA256) upstream package : 5eadb7efc8c195371b0417f5870913226abba49c51cbc6dd4bdc569ae0b3117d

OK

Generated by fedora-review 0.3.1 (f4bc12d) last change: 2012-10-16
Buildroot used: fedora-rawhide-vanilla-x86_64
Command line :./try-fedora-review -b922481

Comment 2 Tom Hughes 2013-04-05 21:55:10 UTC
New Package SCM Request
=======================
Package Name: nodejs-JSV
Short Description: JSON Schema Validator
Owners: tomh
Branches: f19 f18
InitialCC:

Comment 3 Pavol Babinčák 2013-04-08 09:00:54 UTC
Git done (by process-git-requests).

Comment 4 Fedora Update System 2013-04-08 11:39:52 UTC
nodejs-node-markdown-0.1.1-1.fc18,nodejs-JSV-4.0.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nodejs-node-markdown-0.1.1-1.fc18,nodejs-JSV-4.0.2-2.fc18

Comment 5 Fedora Update System 2013-04-08 22:59:43 UTC
nodejs-node-markdown-0.1.1-1.fc18, nodejs-JSV-4.0.2-2.fc18 has been pushed to the Fedora 18 testing repository.

Comment 6 Fedora Update System 2013-04-17 00:21:33 UTC
nodejs-node-markdown-0.1.1-1.fc18, nodejs-JSV-4.0.2-2.fc18 has been pushed to the Fedora 18 stable repository.


Note You need to log in before you can comment on or make changes to this bug.