Bug 922665 - t400 unable to use external display with 3.8.3-201.fc18.x86_64
Summary: t400 unable to use external display with 3.8.3-201.fc18.x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 922304
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 18
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-18 08:45 UTC by Lubos Kocman
Modified: 2013-03-19 13:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-19 13:20:07 UTC


Attachments (Terms of Use)

Description Lubos Kocman 2013-03-18 08:45:04 UTC
Description of problem:

External display is not receiving any input from the system with 3.8.3-201.fc18.x86_64. I've tried both vga/dvi inputs and tried to connect display trough dock and directly to the laptop.

So far xrandr and gnome-config-display sees the second display but as I said the display itself does not detect and input at all. I've tried to switch display layouts with fn+f7 but so far I never got to a point that display panel would display anything.

workaround is to use older kernel (3.8.2-206.fc18.x86_64) which works.



Version-Release number of selected component (if applicable):
rpm -q xorg-x11-drv-intel kernel xorg-x11-server-Xorg
xorg-x11-drv-intel-2.21.4-1.fc18.x86_64
kernel-3.8.2-206.fc18.x86_64 (works)
kernel-3.8.3-201.fc18.x86_64 (does not work)
xorg-x11-server-Xorg-1.13.3-1.fc18.x86_64


How reproducible:


Steps to Reproduce:
1. boot t400 with kernel-3.8.3-201.fc18.x86_64 
2. connect external display to laptop
3. configure any display layout which is using external display
  
Actual results:

external display does not receive any input (internal display works)


Expected results:

external display should work
[lkocman@localhost ~]$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)

Additional info:

using older kernel solves the problem

Comment 1 Martin Horauer 2013-03-18 19:46:42 UTC
I' experiencing the same feature on a Lenovo X200 with an Ultrabase using 

kernel-PAE-devel.i686       3.8.3-201.fc18

Comment 2 Josh Boyer 2013-03-18 20:15:04 UTC
Please test:

https://admin.fedoraproject.org/updates/kernel-3.8.3-203.fc18

Comment 3 Martin Horauer 2013-03-19 06:45:21 UTC
This one is fine, at least on my X200! Thanks!

Comment 4 Lubos Kocman 2013-03-19 09:01:52 UTC
Works for me (t400). Lubos

Comment 5 Josh Boyer 2013-03-19 13:20:07 UTC

*** This bug has been marked as a duplicate of bug 922304 ***


Note You need to log in before you can comment on or make changes to this bug.