Bug 92274 - Put 'nofb' option in F3 menu for syslinux
Summary: Put 'nofb' option in F3 menu for syslinux
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-04 14:07 UTC by Gavin Owen
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 20:17:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gavin Owen 2003-06-04 14:07:10 UTC
Description of problem:
Monitor constantly flashes as refresh rate is set too high. This has been noted 
in earlier RH 6.1. It was fixed in RH 8.0 but is broken again in RH 9.

If affects all types of installs - graphical or text. I've tried all 
combinations of the following: 'skipdcc' 'noprobe' and 'lowres' all to no 
avail. Things work with this monitor once the install is finished, but I 
shouldn't have to swap monitors just to install the product.

Version-Release number of selected component (if applicable):
Anaconda in Redhat 9.

How reproducible:
Very. Happens every time. I'm connected to a GeForce4 Ti4200 with 64MB RAM on 
an Asus A7N8X Deluxe Nvidia NForce motherboard.


Steps to Reproduce:
1. Boot from CD.
2. Choose install method.
3. Watch the monitor flash

Comment 1 Bill Nottingham 2003-06-10 23:14:15 UTC
What are the specs for the monitor?

Comment 2 Gavin Owen 2003-06-13 13:11:24 UTC
When I probe the monitor with redhat-config-xfree86 it says:
30-69 horizontal
50-120 vertical

MonitorsDB in hwdata of both RH8.0 and RH9 have:
Compaq; Compaq V75 Color Monitor; cpq1332; 31.5-69.0; 50.0-100.0; 1

It's definitely a Compaq V75 monitor, Model no. 623T.

I have no problems with flashing monitor in RH8.0 install. By flashing I mean
the image displays for a split second, then blanks for a few seconds, then
displays the image for another spilt second, and so on and so on.

In RH9 it is fine up at the boot prompt of Anaconda. It's only after I choose an
install method does the trouble start. Does this sound like a bug in the
installer kernel? Once I've installed with another monitor, I can swap the V75
back in, run redhat-config-xfree86 and then be up and running fine (I'm typing
on said monitor now). Ideas?

Comment 3 Bill Nottingham 2003-06-13 16:29:11 UTC
OK, so, the numbers you get (30-69, 50-120) are directly from the monitor via DDC.

What happens if you boot with 'nofb'?

Comment 4 Gavin Owen 2003-06-14 11:12:43 UTC
Chosing "linux nofb" fixes the problem.

Is it possible to get this option added to the F3-General initial boot menu text
or to the install guide? The official Redhat Linux Installation Guide
(MAN0059AP) which I got on my RH300 course lists 34 Boot Time Command Arguments;
unfortunately 'nofb' is not one of them.

Hopefully you can resolve the framebuffer problem, which occurs with my Asus
A7N8X Deluxe (rev 1.04) motherboard (with latest BIOS update) and Compaq V75
monitor. The problem doesn't occur at install time when I've got the IBM 9512
T541 flat panel monitor hooked up. These are the only two monitors I've tried.
Thanks.

Comment 5 Bill Nottingham 2003-06-16 04:36:12 UTC
nofb is in the install guide, AFAIK. Assigning to anaconda so it might be put on
the F3 menu.

Comment 6 Jeremy Katz 2003-06-20 22:56:34 UTC
Fixed in CVS

Comment 7 Mike McLean 2003-08-14 20:17:48 UTC
confirmed. closing.


Note You need to log in before you can comment on or make changes to this bug.