Bug 922770 - tog-pegasus 2.12.0 is FTBFS on ARM
tog-pegasus 2.12.0 is FTBFS on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tog-pegasus (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-03-18 09:14 EDT by Peter Robinson
Modified: 2013-05-24 16:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: tog-pegasus-2.12.1-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:26:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to replace ARM (XScale) atomic operations (4.55 KB, patch)
2013-04-22 16:25 EDT, D. Marlin
no flags Details | Diff

  None (edit)
Description Peter Robinson 2013-03-18 09:14:14 EDT
2.12.x is FTBFS on ARM. Previous versions built OK

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1600986


./bin/TestScope +++++ passed all tests
./bin/TestStack +++++ passed all tests
./bin/TestStopwatch +++++ passed all tests
./bin/TestStrToInstName +++++ passed all tests
./bin/TestString +++++ passed all tests
./bin/TestTimeValue +++++ passed all tests
./bin/TestToMof +++++ passed all tests
make[1]: *** [prestarttests_internal] Segmentation fault
make: *** [prestarttests] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.fLnGL9 (%check)
RPM build errors:
    bogus date in %changelog: Wed Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 2:2.9.0-5
    bogus date in %changelog: Mon Jun 16 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 2:2.9.0-1
    Bad exit status from /var/tmp/rpm-tmp.fLnGL9 (%check)
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
Comment 1 Gwyn Ciesla 2013-03-19 09:52:31 EDT
Fixed up bad dates in rawhide, but still fails on my rpi.  Investigating.
Comment 2 Vitezslav Crhonek 2013-03-19 10:18:47 EDT
Build is finished fine, the error occurs in %check section. One of the test binary segfaults on ARM.
Comment 3 D. Marlin 2013-04-22 16:25:33 EDT
Created attachment 738673 [details]
Patch to replace ARM (XScale) atomic operations

This patch replaces the XScale and x86 GNU platform specific assembly code for atomic operations with platform-neutral code from GCC builtins (libatomic).
Comment 4 D. Marlin 2013-04-22 16:26:47 EDT
I believe the issue is in the atomic operations on ARM:

  src/Pegasus/Common/AtomicInt.h

The code there was old (XScale), and did not work on modern ARM SOCs.  I replaced that code with platform neutral code using GCC built-ins (libatomic), and was able to successfully complete a build.

Since the new code is platform neutral, I also tried replacing the x86 GNU atomic operations with the same (shared) code, and a scratch build completed successfully on both ARM and x86:

  http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1735474
  http://koji.fedoraproject.org/koji/taskinfo?taskID=5289828

I have uploaded a patch for 2.12.1 that makes the above changes.
Comment 5 D. Marlin 2013-05-02 09:20:37 EDT
A newer patch has been submitted upstream.  Please see:

  http://bugzilla.openpegasus.org/show_bug.cgi?id=9646

If accepted, it will be applied to the trunk and 2.12-branch.
Comment 6 D. Marlin 2013-05-06 12:35:30 EDT
This has now been commited upstream.

  http://bugzilla.openpegasus.org/show_bug.cgi?id=9646

Please pull in these changes for the Fedora 18 and 19 builds.
Comment 7 Fedora Update System 2013-05-07 09:13:44 EDT
tog-pegasus-2.12.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/tog-pegasus-2.12.1-3.fc19
Comment 8 Fedora Update System 2013-05-07 16:46:27 EDT
Package tog-pegasus-2.12.1-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tog-pegasus-2.12.1-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7611/tog-pegasus-2.12.1-3.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-05-24 16:26:35 EDT
tog-pegasus-2.12.1-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.