Bug 92279 - ATA Raid driver for Compaq Proliant ML310 server missing from installation disks
ATA Raid driver for Compaq Proliant ML310 server missing from installation disks
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-04 10:39 EDT by Richard H. Walter
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 13:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard H. Walter 2003-06-04 10:39:59 EDT
Description of problem:
Attempted installation of Redhat 8.0 from CD's created by downloading iso's.  
Iso CD's were previously verified during installation of another machine.  

Target server is a Compaq ML310 with an integrated LSI Logic dual 
channel "MegarIDE" ATA raid controller.  On installation the 4x40 gig drives 
were configured as 2 78 gig RAID 0's using the on board setup utility and 
initialized.  

On reboot to the installation CD everything appears normal until one arrives 
at the disk partitioning step where you are presented with 4 40 gigabyte 
drives hda, hdb, hdc, hdd rather that 2 arrays sda, sdb.  You can proceed and 
partition the drives, in which case GRUB will fail on boot up and you will be 
forced to boot from a floppy.

The machine was successfully configured with the two RAID arrays using Redhat 
7.3, which installation disks do not contain the driver either.  A version 7.3 
DUD disk with the driver and instructions is available for download from the 
HP website.  When the partitioning screen was reached, this version properly 
reported two arrays, sda and sdb.

Opening an email support case with HP yielded the fact that HP understood that 
the driver was included in the Redhat 8 installation disks.  Ironically, they 
have an RPM for the latest Megaide driver on their website, which appears 
useless as it is necessary to have the OS installed prior to use. There is no 
Redhat 8 DUD disk with this driver available.

I attempted to complete the Redhat 8 installation with the above procedure 
using the 7.3 driver and the DUD.  It failed to load.

I also attemted to do an Upgrade installation of Redhat 8.0 on the 7.3 
configured server.  Anaconda reported that there were no upgradable drives on 
the system.

Regards,
Richard H. Walter


Version-Release number of selected component (if applicable):
Installation ISO's, previously verified for installation on another server 
(not an ML310 obviously)

How reproducible:
100%

Steps to Reproduce:
1.Boot server into the ROM based setup RBSU (F9) utility and configure boot 
order with Raid controller as number 1, cdrom as 2.
2.Reboot server into the on board raid configuration utility (F8) and 
configure as RAID 0, then initialize each array using the same utility.
3.Reboot server with installation CD in place and make selections until the 
disk partitioning screen is reached.
4.Disk partioning screen will show individual drives rather than the 
configured array.
5.  If above steps are repeated using 7.3 installation disks and a DUD floppy 
created from the download available from HP, type in "linux dd upgrades" on 
the first installation screen and proceed through to normal installation with 
properly configured arrays.    

Actual results:

On the first attempt, I partitioned all the drives and completed 
installation.  I then found that GRUB hung.  I then created a boot floppy and 
booted to it.  Things worked normally, just no RAID array and 4 individual 
drives.  

Expected results:

I expected to see two arrays to partition, rather than 4 individual drives.  I 
also expected the boot-up to happen normally, with no problems from GRUB.

Additional info:

This hardware (the ML310 with ATA raid) is listed on both HP's and Red Hat's 
sites as highly compatible with Red Hat 8.0.  Obviously, that it is not so as 
it is currently not possible to install Red Hat 8 on the machine and have it 
function normally.  At a minimum, a driver update disk is necessary to support 
the installation.  

I also opened up a phone case with Red Hat about this.  The technician was 
unable to help me and refunded my incident fee.

There is also notation on the HP website about kernel limitations with the 
Megaide drivers (7.3 and 8.0)
Comment 1 Richard H. Walter 2003-06-06 13:31:33 EDT
Compaq/HP support has resolved this issue by providing a Red Hat 8.0 Driver 
Update Disk.  They emailed it to me, I tested it and it worked for the purpose 
of upgrading the system from Red Hat 7.3 to Red Hat 8.0, albeit with slight 
modification to the written procedure about the boot order on the upgrade, vs. 
the new installation.  

As mentioned, there are kernel limitations clearly spelled out in the DUD's 
documentation.

Affected users can currently call HP/Compaq tech support to obtain the update, 
but the disk image should be posted on their website shortly.


Note You need to log in before you can comment on or make changes to this bug.