Bug 9228 - karchie segfaults
Summary: karchie segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-08 15:54 UTC by Brock Organ
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-16 00:22:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brock Organ 2000-02-08 15:54:37 UTC
[root@test95 /root]# karchie
Segmentation fault (core dumped)
[root@test95 /root]#

Comment 1 Bernhard Rosenkraenzer 2000-02-08 16:06:59 UTC
Doesn't happen here (dist-6.2 as of this morning) anymore.

Comment 2 Brock Organ 2000-03-04 22:35:59 UTC
this still occurs in kdenetwork-1.1.2-12 w/internal build as of Mar 04 ...

[root@test131 /root]# karchie
Segmentation fault (core dumped)
[root@test131 /root]# rpm -q kdenetwork
kdenetwork-1.1.2-12
[root@test131 /root]#

more info:

[root@test131 /root]# strace karchie
execve("/usr/bin/karchie", ["karchie"], [/* 25 vars */]) = 0
brk(0)                                  = 0x806cc60
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40014000
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or directory)
open("/usr/lib/i686/mmx/libkfile.so.2", O_RDONLY) = -1 ENOENT (No such file or
directory)
stat("/usr/lib/i686/mmx", 0xbffff450)   = -1 ENOENT (No such file or directory)

<... boring stuff removed ...>

open("/usr/share/toolbar/down.xpm", O_RDONLY) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=778, ...}) = 0
read(4, "/* XPM */\n/* D", 14)          = 14
fstat(4, {st_mode=S_IFREG|0644, st_size=778, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40499000
_llseek(4, 0, [0], SEEK_SET)            = 0
_llseek(4, 0, [0], SEEK_SET)            = 0
read(4, "/* XPM */\n/* Drawn  by Mark Dono"..., 4096) = 778
close(4)                                = 0
munmap(0x40499000, 4096)                = 0
writev(3, [{"\2\0\4\0,\0@\4\0\10\0\0\177\3402\0005\20\4\0-\0@\4&\0\0"..., 1896},
{"Y\316Y\316Y\316Y\316Y\316Y\316Y\316Y\316Y\316Y\316Y\316"..., 968}], 2) = 2864
open("&Open Dir", O_RDONLY)             = -1 ENOENT (No such file or directory)
open("&Download...", O_RDONLY)          = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
[root@test131 /root]#

Comment 3 Cristian Gafton 2000-03-06 21:14:59 UTC
bero, fix this stuff asap.

Comment 4 Bernhard Rosenkraenzer 2000-03-06 22:46:59 UTC
I absolutely can't reproduce it here - karchie works well here, I can't crash it
even when entering stupid data; I've tried it on 4 different machines (3x x86,
1x alpha), and it does just what it should.
What machine are you using?

Comment 5 Cristian Gafton 2000-03-22 18:21:59 UTC
it's an alpha box

Comment 6 Brock Organ 2000-03-23 16:37:59 UTC
it also fails (i386) on the japanese (beta-6.2) version:

#rpm -q kdemultimedia
kdemultimedia-1.1.2-7j1
#karchie
Segmentation fault (core dumped)
#

Comment 7 Ngo Than 2000-09-16 00:22:24 UTC
i have fixed this problem in kdenetwork-1.1.2-18.


Note You need to log in before you can comment on or make changes to this bug.