Bug 92284 - demo account excessive reconnect abuse is unstipulated
demo account excessive reconnect abuse is unstipulated
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
https://xmlrpc.rhn.redhat.com/XMLRPC
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-04 11:31 EDT by Leon Shaner
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 11:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Shaner 2003-06-04 11:31:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
I'm receiving the "abuse" error message, below, even after not trying to connect
for more than 8 hours.

I would think that an 8 hour pause between connects would be MORE than
sufficient to qualify as "reduce the RHN network traffic from [my] system."

There is no indication of how frequently one may attempt to connect without
being considered abusive.

Similarly, the message supplied when there are too many connected demo users
doesn't say anything about how frequently one may try to reconnect (nor that
there's a threshold deemed abusive).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Run up2date demo account, if receive "too many demo account users" message,
retry, repeat...

Actual Results:  Error Message:
    Abuse of Service detected for server xxxxxxxxxx-FPC-6556-RH90 (xxxxxxxxxx)
Error Class Code: 49
Error Class Info:
     You are getting this error because RHN has detected an abuse of
     service from this system and account. This error is triggered when
     your system makes too many connections to Red Hat Network. This
     error can not be triggered under a normal use of the Red Hat Network
     service as configured by default on Red Hat Linux.

     The Red Hat Network services for this system will remain disabled
     until you will reduce the RHN network traffic from your system to
     acceptable limits.

     Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt
     to contact technical support if you think you have received this
     message in error. 

Expected Results:  Successful connect and up2date operation.

Also, if "abuse" threshold is exceeded, the flag should be automatically reset
after an reasonable amount of time (e.g. 15 minutes).

Additional info:
Comment 1 Greg DeKoenigsberg 2003-06-04 11:59:50 EDT
The abuse flag is not triggered unless there has been a history of abuse.  For
demo customers, the abuse flag is only turned off by RHN Engineering after
assessing each case.

"Abuse" is defined algorithmically by the number of checkins a given system
makes.  Typically, the abuse flag is triggered by users who set the up2date
client programatically to connect at an unreasonable interval (i.e. cron up2date
to run every minute).  If you are a demo user, and we're blocking demo access in
favor of our paying customers, then you WILL NOT get service until we open a
window for you to do so -- and if you abuse the service, we'll turn you off. 
Please understand and respect the fact that we MUST reserve the right to protect
our bandwidth for our paying customers.

We will look into your case.

Note You need to log in before you can comment on or make changes to this bug.