Bug 922904 - Firefox exports a broken version of strndup()
Firefox exports a broken version of strndup()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 466626 959558
  Show dependency treegraph
 
Reported: 2013-03-18 14:28 EDT by Stef Walter
Modified: 2013-05-31 22:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: xulrunner-21.0-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 959558 (view as bug list)
Environment:
Last Closed: 2013-03-19 03:38:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 826171 None None None Never

  None (edit)
Description Stef Walter 2013-03-18 14:28:58 EDT
p11-kit is a PKCS#11 module that runs in various contexts. It uses the strndup() function as provided by libc. firefox in f19, exports a broken strndup() function, which does not null terminate its result.

Symptom: When you use p11-kit (with its internal persintence format), you see lines containing corrupted strings, like this:

p11-kit: distrust-diginotar-root-ca.p11-kit: [p11-kit-object-v1]]: unrecognized or invalid section header
p11-kit: distrust-geotrust-ssl-ca.p11-kit: [p11-kit-object-v1]oved:]: unrecognized or invalid section header

This has been fixed upstream at: https://bugzilla.mozilla.org/show_bug.cgi?id=826171
Comment 1 Kai Engert (:kaie) 2013-03-18 16:55:11 EDT
Martin, could you please pick up the patch from the upstream bug and do Firefox builds for both Fedora 18 and Rawhide? It blocks our testing for a new Fedora feature. Thanks in advance.
Comment 2 Martin Stransky 2013-03-19 03:38:13 EDT
Added to xulrunner-19.0.2-3. Do you need to submit it as an update for Fedoras?
Comment 3 Stef Walter 2013-03-19 03:40:56 EDT
(In reply to comment #2)
> Added to xulrunner-19.0.2-3. Do you need to submit it as an update for
> Fedoras?

We need an update for Fedora 19 for sure (since rawhide has branched). I think that an update for Fedora 18 would also be nice.
Comment 4 Fedora Update System 2013-03-19 05:26:55 EDT
xulrunner-19.0.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-19.0.2-3.fc17
Comment 5 Fedora Update System 2013-03-19 05:27:07 EDT
xulrunner-19.0.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-19.0.2-3.fc18
Comment 6 Fedora Update System 2013-03-25 18:54:50 EDT
xulrunner-19.0.2-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-04-23 08:37:44 EDT
xulrunner-20.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-20.0-4.fc18
Comment 8 Fedora Update System 2013-04-23 08:38:09 EDT
xulrunner-20.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-20.0-4.fc17
Comment 9 Fedora Update System 2013-04-23 08:38:28 EDT
xulrunner-20.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xulrunner-20.0-4.fc19
Comment 10 Fedora Update System 2013-04-26 23:10:13 EDT
xulrunner-20.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-05-31 22:28:00 EDT
xulrunner-21.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.