Bug 92296 - MPA section creation/move is broken
Summary: MPA section creation/move is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Archit Shah
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 98546
TreeView+ depends on / blocked
 
Reported: 2003-06-04 17:53 UTC by Richard Li
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 21:41:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Li 2003-06-04 17:53:56 UTC
Description of problem:

Creating and moving sections in a MPA is very strange due to a combination of
poor UI and uncleared Bebop state.

How reproducible:

Always.

Steps to Reproduce:
1. Create a MPA.
2. Create a few sections for the MPA.
3. Move the sections around.
4. Observe the non-intuitive UI.
5. Create a new section.
6. Observe that the section doesn't appear at the end, where one would expect.
(This sort of depends on how you did #3).

Comment 1 Richard Li 2003-06-04 18:08:46 UTC
I did a small improvement to the UI @32009. Not sure if we want to spend
significant amount of time revamping the UI, but I think clearing the Bebop
state would be nice.

Comment 2 Richard Li 2003-06-04 18:13:50 UTC
Oh, I know what I was going to add. Moving around the sections seems to work in
the authoring kit but does not work for the summary. The two don't seem to be
kept in sync. That's the real bug.

Comment 3 Jon Orris 2003-06-18 21:40:29 UTC
Some more info:

Create a new MPA.
Add three sections titled Section 1, Section 2, and Section 3 in that order.
The display order of the sections is
Section 1
Section 3
Section 2

When moving sections, 'Move Below' doesn't work for the last section; you can't
move anything below it.


Comment 4 Jon Orris 2003-07-29 14:31:43 UTC
It's broken again @34045/Oracle 817. Marking as high severity/priority as it is
a regression, setting blocker to RC 1.

Create 3 Sections 1, 2 & 3

Move 3 Below 1: Expected: 1, 3, 2. Actual: Nothing happens
Move 3 to beginning: Expected 3, 1, 2. Actual: 2, 3, 1



Note You need to log in before you can comment on or make changes to this bug.