Bug 922966 - mount: unknown filesystem type 'f2fs'
Summary: mount: unknown filesystem type 'f2fs'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 18
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-18 21:32 UTC by Maxim Prohorenko
Modified: 2013-11-12 09:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-15 09:26:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Maxim Prohorenko 2013-03-18 21:32:19 UTC
Description of problem: f2fs filesystem cannot be mounted.


Version-Release number of selected component (if applicable):

util-linux-2.22.2-6.fc18.x86_64
f2fs-tools-1.0.0-3.fc18.x86_64

How reproducible:
Format f2fs partition


Steps to Reproduce:
1. Format f2fs partition
mkfs.f2fs /dev/sdc1

2. Try mount it
mount -t f2fs /dev/sdc1 /mnt/
  
Actual results:
1. Format - ok
Info: sector size = 512
Info: total sectors = 131134063 (in 512bytes)
Info: zone aligned segment0 blkaddr: 256
Info: This device doesn't support TRIM
Info: format successful

2. Mount - error
mount: unknown filesystem type 'f2fs'

Expected results:
mount: without errors

Additional info:

Comment 1 Karel Zak 2013-03-21 07:36:54 UTC
Are you really sure that the kernel supports f2fs?

 grep F2FS /boot/config-3.8.3-203.fc18.x86_64
 # CONFIG_F2FS_FS is not set

You have to convince fedora kernel maintainers to enable the filesystem :-) Reassigning...

Comment 2 Maxim Prohorenko 2013-03-21 07:46:48 UTC
I build and install kernel module f2fs.ko.
But it does not solve my problem too.
Mount know about f2fs but can't mount disk formatted by mkfs.f2fs

Comment 3 Josh Boyer 2013-03-21 14:09:52 UTC
Yeah, we don't build this.  If you're building it yourself, that's fine but this isn't a fedora kernel problem.

You'll want to show the output of lsmod and /proc/filesystems after you load your driver.

Karel, I'm passing it back to you for now.  If you don't think this is an issue in util-linux then please just close it as NOTABUG or WONTFIX given the fedora kernel doesn't build this filesystem.

Comment 4 Karel Zak 2013-04-15 09:26:47 UTC
Note that libblkid is able to detect f2fs since util-linux 2.23.


Note You need to log in before you can comment on or make changes to this bug.