Bug 92310 - pserver cvs fails to open archive
pserver cvs fails to open archive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-04 15:26 EDT by Phil Muldoon
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-25 11:09:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.log trace (13.08 KB, text/plain)
2003-07-23 19:41 EDT, Jeremy Handcock
no flags Details

  None (edit)
Description Phil Muldoon 2003-06-04 15:26:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
when attempting to connect to a cvs archive in the cvs perspective, connecting
to a pserver enabled cvs server stalls, and fails to connect

Version-Release number of selected component (if applicable):
beehive-compiled; maybe others

How reproducible:
Always

Steps to Reproduce:
1. Attempt connect via CVS perpsective to pserver cvs server
2.
3.
    

Actual Results:  The connection will stall or fail, and sometimes eclipse will
crash. ext servers work fine

Expected Results:  The naviagtor view should have been populated with a list of
projects

Additional info:

First reported by ahussain, then by agreen. Entered by pmuldoon
Comment 1 Tom Tromey 2003-07-21 13:57:05 EDT
I tried this today.

I used this repository:

:pserver:anoncvs@subversions.gnu.org:/cvsroot/monotone

I checked out monotone just fine.
It is a smallish repository.

Can you tell me how you got this to fail?
Comment 2 Phil Muldoon 2003-07-21 14:07:57 EDT
It failed off 2.0.1 system - so it might have been fixed in the 2.1 version.
According to ahussain and agreen, the reporters, any pserver respository would
just fail to connect after an extended connection attempt.  If it works in the
gcj version of 2.1 it may have been fixed through upgrading our sources.
Comment 3 Tom Tromey 2003-07-21 14:11:19 EDT
Ok, I'm closing this as fixed.
Comment 4 Jeremy Handcock 2003-07-23 19:41:05 EDT
Created attachment 93091 [details]
.log trace

I'm still seeing a problem with eclipse 2.1, gcj-compiled.  Try the following
repository :pserver:anonymous@dev.eclipse.org:/home/eclipse

Behavior is the same as Phil described in the initial report.
Comment 5 Tom Tromey 2003-07-24 13:49:36 EDT
I've tried with more repositories (including both eclipse and
one on sourceforge) and still can't reproduce.

The stack trace you attached is suggestive.
This appears to be a "shouldn't happen" situation.
Unless the stack trace is incorrect (possible),
the only possible NullPointerException in
PlainSocketImpl$SocketInputStream.read would occur
if this$0 was null.  But in theory that cannot be the
case.

It might be informative to turn on debugging.
I think you can do this by making a file called
".options" (anyplace is fine -- just run eclipse from
that directory).  In .options, put:

org.eclipse.team.core/streams = true

Then run eclipse with the "-debug" option.

If this works, eclipse will print debug info when
it is connecting to the cvs server.  If you could
attach this log from a failing run, that may give
me the info I need.

If that fails, the next step would be for me to try
to run it from Toronto and debug a failure live.
I really hope to avoid that...
Comment 6 Jeremy Handcock 2003-07-25 11:09:01 EDT
Sigh.  Somehow my libgcj-ssa RPM was left out of my gcc-ssa update a while back,
and consequently, I've been building and testing with
libgcj-ssa-3.5ssa-0.20030428.17.  I updated to libgcj-ssa-3.5ssa-0.20030617.24,
and this bug is gone.  Closing.

Note You need to log in before you can comment on or make changes to this bug.