Bug 923102 - crash in intel_pstate_timer_func on virtualization
crash in intel_pstate_timer_func on virtualization
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-19 04:21 EDT by Tomasz Torcz
Modified: 2013-03-21 10:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 10:51:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
intel_pstate_timer_func-rc3.png (49.66 KB, image/png)
2013-03-19 04:21 EDT, Tomasz Torcz
no flags Details
photo of the trace with 3.9.0-0.rc3.git0.5.fc20.x86_64 (975.27 KB, image/jpeg)
2013-03-20 16:19 EDT, Adam Williamson
no flags Details

  None (edit)
Description Tomasz Torcz 2013-03-19 04:21:41 EDT
Created attachment 712474 [details]
intel_pstate_timer_func-rc3.png

Description of problem:
When running guest in VirtulBox 4.2.10, kernel crashes on boot. See screenshot for backtrace.

Version-Release number of selected component (if applicable):
kernel-3.9.0-0.rc3.git0.3.fc19.x86_64.rpm 

Additional info:
booting is possible only with "intel_pstate=disable"
Comment 1 Dirk Brandewie 2013-03-19 12:17:55 EDT
Please try the patch attatched to bug
https://bugzilla.redhat.com/show_bug.cgi?id=922923
Comment 2 Dave Jones 2013-03-19 14:51:22 EDT
*** Bug 920289 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2013-03-20 13:35:41 EDT
can you try kernel-3.9.0-0.rc3.git0.4.fc19  (without the disable option)
Comment 4 Adam Williamson 2013-03-20 16:17:40 EDT
So I posted in my dupe that this had stopped happening to me, but over the last day or two it (or something like it) has started happening again - if anything more frequently. It's happened three times since last night, twice this morning. I think that ties up with the new kernel Dave mentions, in fact...yeah, looks like I got rc3.git0.5.fc20 (I'm using rawhide-nodebug repo) installed yesterday morning, and would've rebooted into it later that day, then I started seeing freezes again. Twice it was just a freeze at desktop, no trace, but once I got a picture of the trace, will attach.
Comment 5 Adam Williamson 2013-03-20 16:19:05 EDT
Created attachment 713458 [details]
photo of the trace with 3.9.0-0.rc3.git0.5.fc20.x86_64
Comment 6 Dirk Brandewie 2013-03-20 16:33:36 EDT
So something very strange is going on here.  I see pid_param_set() on the stack if the stack trace is accurate then something is diddling the debugfs files for the driver which you should do at your own peril :-)

Is there anyway to capture the beging of the stack trace?

Any thing special happening on the system prior to the freeze?
Comment 7 Adam Williamson 2013-03-20 16:55:34 EDT
Huh. No idea what's going on, but it's exploding on me with regularity now. I booted back to rc3.git3 and it exploded in less than an hour. I can't get anything done like this, I'll have to disable pstate...
Comment 8 Ma Hsiao-chun 2013-03-20 21:47:07 EDT
This probably affects some recent GNOME testing images:
ftp://ftp.gnome.org/pub/GNOME/misc/testing/

I cannot run GNOME-3.7.92.iso at this point.
Comment 9 Adam Williamson 2013-03-20 22:14:19 EDT
Ma: try "intel_pstate=disable" on the cmdline.
Comment 10 Tomasz Torcz 2013-03-21 04:00:08 EDT
Knocking on wood, my original problem seems to be fixed:
# hostnamectl  | egrep  "Virt|Kernel"
    Virtualization: oracle
            Kernel: Linux 3.9.0-0.rc3.git0.4.fc19.x86_64
Comment 11 Dave Jones 2013-03-21 10:48:25 EDT
ok, sounds like Adam is seeing a different bug after all. Let's undupe this, and close this one out as it works for Tomasz.

Adam, I'll have a new debug build later today.

Note You need to log in before you can comment on or make changes to this bug.