Bug 923141 - Scalable app fills disk quota with log files
Scalable app fills disk quota with log files
Status: CLOSED DUPLICATE of bug 876473
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-19 06:02 EDT by development@describability.com
Modified: 2015-05-14 19:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 15:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description development@describability.com 2013-03-19 06:02:14 EDT
Description of problem: On a scalable app, the webpage is requested every 2 seconds. These requests are all logged in /php-5.3/logs/ This caused me to run out of disk space and I then had to manually clear-out the logs.


How reproducible: 100%


Steps to Reproduce:
1. Setup a scalable app.
2. Check the logs in php-5.3/logs/
  

Actual results: A new request is being logged every 2 seconds.


Expected results: Some way to turn off logging of these events would be useful. Obviously the requests are necessary for the scalable functionality, but I would like to be able to disable logging of them. Aside from the issue with using up my quota, it also makes it hard to use the logs to monitor real requests.


Additional info: When I had the issue, my app and data were using 68M and the log files were using the entire rest of my 1Gb quota space.
Comment 1 Luke Meyer 2013-03-21 15:39:30 EDT
This is a longstanding problem and I agree it sucks. Workaround: set up a cron job to delete old logs, run rhc tidy a lot, etc.

There is a user story for improving this, and I will add a note that this sucks not only because it fills up disk space, but because it makes the logs harder to use. The story is currently in Rally as US3111 and invisible publicly - should soon be transferred to Trello and become public.

*** This bug has been marked as a duplicate of bug 876473 ***

Note You need to log in before you can comment on or make changes to this bug.