Bug 923160 - Removal of /usr/share/X11/xkb/keymap.dir breaks NX
Summary: Removal of /usr/share/X11/xkb/keymap.dir breaks NX
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xkeyboard-config
Version: 6.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 835616 994246 1075802 1159931
TreeView+ depends on / blocked
 
Reported: 2013-03-19 10:24 UTC by J.H.M. Dassen (Ray)
Modified: 2018-12-02 18:09 UTC (History)
12 users (show)

Fixed In Version: xkeyboard-config-2.11-3.el6
Doc Type: Bug Fix
Doc Text:
With the previous upgrade to upstream version 2.11, the /usr/share/X11/xkb/keymap.dir file was removed from the xkeyboard-config packages. Consequently, X11 keyboard configuration stopped working for NX connections. This update includes the missing file again, and as a result, the broken functionality is restored.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:10:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CentOS 6298 0 None None None Never
FreeDesktop.org 50553 0 None None None Never
Red Hat Bugzilla 835284 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Bugzilla 914760 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Knowledge Base (Solution) 340743 0 None None None Never
Red Hat Product Errata RHBA-2015:1276 0 normal SHIPPED_LIVE xkeyboard-config bug fix and enhancement update 2015-07-20 17:49:14 UTC

Internal Links: 835284 914760

Description J.H.M. Dassen (Ray) 2013-03-19 10:24:55 UTC
Description of problem:
Through bug 835284, xkeyboard-config was rebased in RHEL6.4. The current package no longer provides a /usr/share/X11/xkb/keymap.dir file. This breaks NX (both Commercial and FreeNX).

Version-Release number of selected component (if applicable):
xkeyboard-config-2.6-6.el6

How reproducible:
100%

Steps to Reproduce:
Cf. <http://bugs.centos.org/view.php?id=6298&nbn=4>
  
Actual results:
Broken keyboard configuration when connecting to a RHEL6.4 system using NX.

Expected results:
Proper keyboard configuration when connecting to a RHEL6.4 system using NX.

Additional info:
Reportedly, a "touch /usr/share/X11/xkb/keymap.dir" is sufficient to make NX work again.

Comment 1 J.H.M. Dassen (Ray) 2013-03-19 10:32:25 UTC
Bugzilla isn't letting me link this to external trackers
	CentOS 6298
	FreeDesktop.org 50553
so noting this here for now.

Comment 2 Peter Hutterer 2013-03-27 05:13:40 UTC
Looking at the NX source, this is indeed the cause and a simple touch of that file is sufficient to fix it.

http://code.x2go.org/gitweb?p=nx-libs.git;a=blob;f=nx-X11/programs/Xserver/xkb/ddxLoad.c;h=e69d956703de78af77602587cfd77478a39afbfc;hb=HEAD#l189


NXVerifyXkbBaseDirectory() uses that file to verify that a directory path is an xkb directory. It doesn't look at the file otherwise, so shipping an empty file would be sufficient.

Comment 15 Peter Hutterer 2014-11-25 01:08:40 UTC
We can revert the change in xkeyboard-config, that'll ensure the required files are shipped. Note that this will still not enable NX to work, see Bug 1157866.

Comment 16 Peter Hutterer 2014-12-02 22:14:48 UTC
Workaround as pointed out in Comments #0 and #2 seems to be:
  touch //usr/share/X11/xkb/keymap.dir

This assessment is based on the X2go source code [1] as of version 3.5.0.28. The FreeNX sources are down and unavailable for verification, and the commercial one from nomachine seems to work fine (v4.3.30)

[1] http://code.x2go.org/gitweb?p=nx-libs.git;a=blob;f=nx-X11/programs/Xserver/xkb/ddxLoad.c;h=e69d956703de78af77602587cfd77478a39afbfc;hb=HEAD#l189

Comment 17 Peter Hutterer 2014-12-16 06:26:19 UTC
MODIFIED

xkeyboard-config-2.11-2.el6 is available in brew

Comment 19 Peter Hutterer 2015-01-16 04:07:53 UTC
Updated package.

xkeyboard-config-2.11-3.el6 is available in brew

Comment 20 Michael Boisvert 2015-04-29 17:48:48 UTC
Verified on xkeyboard-config-2.11-3.el6. The file: /usr/share/X11/xkb/keymap.dir has been restored.

Comment 22 errata-xmlrpc 2015-07-22 06:10:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1276.html


Note You need to log in before you can comment on or make changes to this bug.