Bug 9232 - Null password badly processed
Summary: Null password badly processed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pwdb (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-08 18:10 UTC by Patrick Monnerat
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 02:34:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Monnerat 2000-02-08 18:10:01 UTC
After upgrade to RH6.1, I was not able to log on: my login was not
password-protected (Not a NW machine!). The system always asked for a
password and failed, whatever was the answer.
Since "nullok" was specified in the PAM file, it should have been working.
Hints for fix: My own investigations showed me that in the
libpwdb/interface/unix/user.c, a test is made for "strlen(storedpassword)
> 1" where the comments say " != 1"... The comment is right, since the
code redirects the null password processing to a non-existent shadow
password file.
After fixing as above and recompiling libpwd, the null password feature is
OK!
I may also suggest this bug affects the "passwd" command... check

Comment 1 Cristian Gafton 2000-05-22 15:37:59 UTC
assigned to nalin

Comment 2 Patrick Monnerat 2000-06-13 12:03:19 UTC
... seems to be fixed in RedHat 6.2 with the new version of pwdb (the same way 
I did!)


Note You need to log in before you can comment on or make changes to this bug.