Bug 923233 - [abrt] ninja-ide-2.1.1-4.fc18: highlighter.py:326:realtime_highlight:AttributeError: 'QTextBlockUserData' object has no attribute 'clear_data'
Summary: [abrt] ninja-ide-2.1.1-4.fc18: highlighter.py:326:realtime_highlight:Attribut...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PyQt4
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5562e81d1a744ef4f0d83015404...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-19 13:47 UTC by Randy Barlow
Modified: 2013-05-14 01:25 UTC (History)
5 users (show)

Fixed In Version: sip-4.14.6-1.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-02 04:36:08 UTC


Attachments (Terms of Use)
File: backtrace (925 bytes, text/plain)
2013-03-19 13:47 UTC, Randy Barlow
no flags Details
File: core_backtrace (401 bytes, text/plain)
2013-03-19 13:47 UTC, Randy Barlow
no flags Details
File: environ (1.85 KB, text/plain)
2013-03-19 13:47 UTC, Randy Barlow
no flags Details

Description Randy Barlow 2013-03-19 13:47:10 UTC
Version-Release number of selected component:
ninja-ide-2.1.1-4.fc18

Additional info:
cmdline:        /usr/bin/python /usr/bin/ninja-ide
executable:     /usr/bin/ninja-ide
kernel:         3.8.2-206.fc18.x86_64
uid:            1000

Truncated backtrace:
highlighter.py:326:realtime_highlight:AttributeError: 'QTextBlockUserData' object has no attribute 'clear_data'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ninja_ide/gui/editor/highlighter.py", line 244, in highlightBlock
    self.highlight_function(text)
  File "/usr/lib/python2.7/site-packages/ninja_ide/gui/editor/highlighter.py", line 253, in open_highlight
    self.realtime_highlight(text)
  File "/usr/lib/python2.7/site-packages/ninja_ide/gui/editor/highlighter.py", line 326, in realtime_highlight
    user_data.clear_data()
AttributeError: 'QTextBlockUserData' object has no attribute 'clear_data'

Local variables in innermost frame:
text: PyQt4.QtCore.QString(u'#!/usr/bin/python')
self: <ninja_ide.gui.editor.highlighter.Highlighter object at 0x34a9050>
hls: []
user_data: <PyQt4.QtGui.QTextBlockUserData object at 0x34a9440>
block: <PyQt4.QtGui.QTextBlock object at 0x34a93b0>

Comment 1 Randy Barlow 2013-03-19 13:47:12 UTC
Created attachment 712677 [details]
File: backtrace

Comment 2 Randy Barlow 2013-03-19 13:47:13 UTC
Created attachment 712678 [details]
File: core_backtrace

Comment 3 Randy Barlow 2013-03-19 13:47:15 UTC
Created attachment 712679 [details]
File: environ

Comment 4 Nikos Roussos 2013-04-26 17:00:35 UTC
This seems to be a PyQT4.
http://www.riverbankcomputing.com/pipermail/pyqt/2013-March/032457.html

Re-assigning to see if it's resolved upstream.

Comment 5 Rex Dieter 2013-04-26 17:44:29 UTC
I cannot reproduce the problem using:

$ rpm -q ninja-ide sip PyQt4
ninja-ide-2.1.1-4.fc18.noarch
sip-4.14.5-1.fc18.x86_64
PyQt4-4.10-1.fc18.x86_64

Maybe was already fixed with:
https://admin.fedoraproject.org/updates/FEDORA-2013-4559/sip-4.14.5-1.fc18
?

Comment 6 Rex Dieter 2013-04-26 17:46:39 UTC
I take it back, had to play with it a bit first (without any instructions here how to reproduce... *cough* :) )

confirmed crash, I'll try to play with a few things and let you know...

Comment 7 Randy Barlow 2013-04-26 18:48:03 UTC
Apologies for lack of reproduction instructions. I never found a specific way to cause it to happen. Let me know if you need any further information, and thanks!

Comment 8 Rex Dieter 2013-04-26 18:58:52 UTC
confirmed (seems!) fixed with sip-4.14.6 + PyQt4-4.10.1

I'll get to work on prepping updates.

Comment 9 Fedora Update System 2013-04-27 13:19:41 UTC
PyQt4-4.10.1-2.fc19,sip-4.14.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/PyQt4-4.10.1-2.fc19,sip-4.14.6-1.fc19

Comment 10 Fedora Update System 2013-04-27 13:20:07 UTC
PyQt4-4.10.1-2.fc18,sip-4.14.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/PyQt4-4.10.1-2.fc18,sip-4.14.6-1.fc18

Comment 11 Fedora Update System 2013-04-27 13:20:41 UTC
PyQt4-4.10.1-2.fc17,sip-4.14.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/PyQt4-4.10.1-2.fc17,sip-4.14.6-1.fc17

Comment 12 Fedora Update System 2013-04-27 17:26:50 UTC
Package PyQt4-4.10.1-2.fc19, sip-4.14.6-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PyQt4-4.10.1-2.fc19 sip-4.14.6-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6795/PyQt4-4.10.1-2.fc19,sip-4.14.6-1.fc19
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-05-02 04:36:10 UTC
PyQt4-4.10.1-2.fc19, sip-4.14.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-05-14 01:23:04 UTC
sip-4.14.6-1.fc18, PyQt4-4.10.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-05-14 01:25:26 UTC
sip-4.14.6-1.fc17, PyQt4-4.10.1-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.