Bug 92330 - Actions -> Start Service; Stop Service; Restart Service availability.
Summary: Actions -> Start Service; Stop Service; Restart Service availability.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-services   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-05 05:50 UTC by Justin Szeto
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 18:20:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Szeto 2003-06-05 05:50:04 UTC
If a service is already started, should Actions -> Start Service & Restart
Service be shaded in the menu?  Likewise for the toolbar.

And conversely, if it is stopped, Actions -> Stop Service should be shaded and
likewise for the toolbar.

Sorry again for the lameness... let me know please and I will go away!

Version-Release number of selected component (if applicable):
redhat-config-services  0.8.4

How reproducible:
Always

Steps to Reproduce: No help required.
  
Actual Results: Not applicable.

Expected Results: Self Explanatory.

Comment 1 Daniel Walsh 2003-06-05 18:20:26 UTC
Thanks for reviewing this.  The problem is that the status can easily change
there is really no way to know if a service is running.  Linux does not have a
way of registering a service as running or not running.  The only thing we can
do is run
/sbin/service SERVICE status.  But that does not give standard output.  So the
best we can do is display the output of that command and allow a human to decide
if the service is running or not.




Note You need to log in before you can comment on or make changes to this bug.