Bug 923468 - ARM preprocessor handling needed to build package
ARM preprocessor handling needed to build package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: filebench (Show other bugs)
19
arm Linux
unspecified Severity high
: ---
: ---
Assigned To: Hushan Jia
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-03-19 19:17 EDT by William Henry
Modified: 2013-03-19 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 19:41:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff to ioprio.c (390 bytes, patch)
2013-03-19 19:17 EDT, William Henry
no flags Details | Diff

  None (edit)
Description William Henry 2013-03-19 19:17:41 EDT
Created attachment 712993 [details]
diff to ioprio.c

Description of problem:

filebench package does not build because it is missing a preprocessor define for ARM.  

Interestingly the two #defines it needs are defined for ARM elsewhere (/usr/include/asm/unistd.h) so it only needed to define a handler in ioprio.c to get over the no arch issue.

So just added the following lines. 

#elif defined(__arm__)
#ifndef __NR_ioprio_set
#define __NR_ioprio_set         314
#define __NR_ioprio_get         315
#endif

That got the build working. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Robinson 2013-03-19 19:41:41 EDT
Fixed. Thanks for the patch

Note You need to log in before you can comment on or make changes to this bug.