Bug 923477 - SELinux is preventing /usr/bin/bash from 'execute_no_trans' accesses on the file /etc/NetworkManager/dispatcher.d/00-netreport.
Summary: SELinux is preventing /usr/bin/bash from 'execute_no_trans' accesses on the f...
Keywords:
Status: CLOSED DUPLICATE of bug 923497
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a6c91ef1229b3f29be5a6f9ce27...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-03-19 23:57 UTC by Adam Williamson
Modified: 2013-03-20 00:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-20 00:55:45 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2013-03-19 23:57:20 UTC
Description of problem:
Occurs on boot of a Fedora 19 live image built from current repositories. SEalert claims the label is wrong, but if so, it's nothing I did.
SELinux is preventing /usr/bin/bash from 'execute_no_trans' accesses on the file /etc/NetworkManager/dispatcher.d/00-netreport.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/etc/NetworkManager/dispatcher.d/00-netreport default label should be NetworkManager_initrc_exec_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /etc/NetworkManager/dispatcher.d/00-netreport

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that bash should be allowed execute_no_trans access on the 00-netreport file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep 00-netreport /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:net_conf_t:s0
Target Objects                /etc/NetworkManager/dispatcher.d/00-netreport [
                              file ]
Source                        00-netreport
Source Path                   /usr/bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.45-1.fc19.x86_64
Target RPM Packages           initscripts-9.45-2.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-22.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.0-0.rc3.git0.3.fc19.x86_64 #1
                              SMP Mon Mar 18 21:39:31 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-03-19 19:40:42 EDT
Last Seen                     2013-03-19 19:40:42 EDT
Local ID                      337afc8a-8e18-475d-a0c5-31e75ed5a9c6

Raw Audit Messages
type=AVC msg=audit(1363736442.296:396): avc:  denied  { execute_no_trans } for  pid=2246 comm="nm-dispatcher.a" path="/etc/NetworkManager/dispatcher.d/00-netreport" dev="dm-0" ino=293023 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:net_conf_t:s0 tclass=file


type=SYSCALL msg=audit(1363736442.296:396): arch=x86_64 syscall=execve success=yes exit=0 a0=acab90 a1=7fffd881a380 a2=acb620 a3=7fffd8819ed0 items=0 ppid=2235 pid=2246 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=00-netreport exe=/usr/bin/bash subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: 00-netreport,system_dbusd_t,net_conf_t,file,execute_no_trans

audit2allow

#============= system_dbusd_t ==============
allow system_dbusd_t net_conf_t:file execute_no_trans;

audit2allow -R
require {
	type net_conf_t;
	type system_dbusd_t;
	class file execute_no_trans;
}

#============= system_dbusd_t ==============
allow system_dbusd_t net_conf_t:file execute_no_trans;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.0-0.rc3.git0.3.fc19.x86_64
type:           libreport

Comment 1 Adam Williamson 2013-03-20 00:02:07 UTC
Final blocker: "In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login"

Comment 2 Daniel Walsh 2013-03-20 00:55:45 UTC

*** This bug has been marked as a duplicate of bug 923497 ***


Note You need to log in before you can comment on or make changes to this bug.