Bug 923479 - SELinux is preventing nm-dispatcher.a from 'execute' accesses on the file 11-dhclient.
Summary: SELinux is preventing nm-dispatcher.a from 'execute' accesses on the file 11-...
Keywords:
Status: CLOSED DUPLICATE of bug 923497
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b3eba2ef5a4fe662fda2d4d6ebd...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-03-20 00:02 UTC by Adam Williamson
Modified: 2013-03-20 00:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-20 00:55:38 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2013-03-20 00:02:37 UTC
Description of problem:
Occurs on boot of a Fedora 19 live image built from current repositories.
SELinux is preventing nm-dispatcher.a from 'execute' accesses on the file 11-dhclient.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that nm-dispatcher.a should be allowed execute access on the 11-dhclient file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep nm-dispatcher.a /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:net_conf_t:s0
Target Objects                11-dhclient [ file ]
Source                        nm-dispatcher.a
Source Path                   nm-dispatcher.a
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.45-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-22.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.0-0.rc3.git0.3.fc19.x86_64 #1
                              SMP Mon Mar 18 21:39:31 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-03-19 19:40:42 EDT
Last Seen                     2013-03-19 19:40:43 EDT
Local ID                      de63a643-9d7b-4662-8be2-50fb18d8f70b

Raw Audit Messages
type=AVC msg=audit(1363736443.683:417): avc:  denied  { execute } for  pid=2399 comm="nm-dispatcher.a" name="11-dhclient" dev="dm-0" ino=293281 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:net_conf_t:s0 tclass=file


type=AVC msg=audit(1363736443.683:417): avc:  denied  { execute_no_trans } for  pid=2399 comm="nm-dispatcher.a" path="/etc/NetworkManager/dispatcher.d/11-dhclient" dev="dm-0" ino=293281 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:net_conf_t:s0 tclass=file


type=SYSCALL msg=audit(1363736443.683:417): arch=x86_64 syscall=execve success=yes exit=0 a0=aca210 a1=7fffd881a8d0 a2=ace8a0 a3=7fffd881a420 items=0 ppid=2235 pid=2399 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=11-dhclient exe=/usr/bin/bash subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: nm-dispatcher.a,system_dbusd_t,net_conf_t,file,execute

audit2allow

#============= system_dbusd_t ==============
allow system_dbusd_t net_conf_t:file { execute execute_no_trans };

audit2allow -R
require {
	type net_conf_t;
	type system_dbusd_t;
	class file { execute execute_no_trans };
}

#============= system_dbusd_t ==============
allow system_dbusd_t net_conf_t:file { execute execute_no_trans };


Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.0-0.rc3.git0.3.fc19.x86_64
type:           libreport

Comment 1 Adam Williamson 2013-03-20 00:02:54 UTC
Final blocker: "In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login"

Comment 2 Daniel Walsh 2013-03-20 00:55:38 UTC

*** This bug has been marked as a duplicate of bug 923497 ***


Note You need to log in before you can comment on or make changes to this bug.