Bug 923487 - SELinux is preventing gdm from 'execute' accesses on the file gdm-simple-slave.
Summary: SELinux is preventing gdm from 'execute' accesses on the file gdm-simple-slave.
Keywords:
Status: CLOSED DUPLICATE of bug 923497
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f2b2c5385b2d02dfbe423860962...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-03-20 00:10 UTC by Adam Williamson
Modified: 2013-03-20 00:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-20 00:40:26 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2013-03-20 00:10:55 UTC
Description of problem:
Occurs on boot of a Fedora 19 live image built from current repositories.
SELinux is preventing gdm from 'execute' accesses on the file gdm-simple-slave.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gdm should be allowed execute access on the gdm-simple-slave file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gdm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:root_t:s0
Target Objects                gdm-simple-slave [ file ]
Source                        gdm
Source Path                   gdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-22.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.0-0.rc3.git0.3.fc19.x86_64 #1
                              SMP Mon Mar 18 21:39:31 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-03-19 19:39:23 EDT
Last Seen                     2013-03-19 19:39:23 EDT
Local ID                      9404611e-3c5d-4300-9a7d-ed9364d8a21f

Raw Audit Messages
type=AVC msg=audit(1363736363.965:85): avc:  denied  { execute } for  pid=784 comm="gdm" name="gdm-simple-slave" dev="dm-0" ino=180453 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:root_t:s0 tclass=file


type=AVC msg=audit(1363736363.965:85): avc:  denied  { read open } for  pid=784 comm="gdm" path="/usr/libexec/gdm-simple-slave" dev="dm-0" ino=180453 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:root_t:s0 tclass=file


type=AVC msg=audit(1363736363.965:85): avc:  denied  { execute_no_trans } for  pid=784 comm="gdm" path="/usr/libexec/gdm-simple-slave" dev="dm-0" ino=180453 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:root_t:s0 tclass=file


Hash: gdm,xdm_t,root_t,file,execute

audit2allow

#============= xdm_t ==============
allow xdm_t root_t:file { read execute open execute_no_trans };

audit2allow -R
require {
	type xdm_t;
	type root_t;
	class file { read execute open execute_no_trans };
}

#============= xdm_t ==============
allow xdm_t root_t:file { read execute open execute_no_trans };


Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.0-0.rc3.git0.3.fc19.x86_64
type:           libreport

Comment 1 Adam Williamson 2013-03-20 00:11:12 UTC
Final blocker: "In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login"

Comment 2 Daniel Walsh 2013-03-20 00:40:26 UTC

*** This bug has been marked as a duplicate of bug 923497 ***


Note You need to log in before you can comment on or make changes to this bug.