Bug 923489 - SELinux is preventing /usr/sbin/modem-manager from 'read' accesses on the file udev.conf.
Summary: SELinux is preventing /usr/sbin/modem-manager from 'read' accesses on the fil...
Keywords:
Status: CLOSED DUPLICATE of bug 923497
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ac97ccfda7ba00e0d21d59bd5dc...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-03-20 00:12 UTC by Adam Williamson
Modified: 2013-03-20 00:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-20 00:38:50 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2013-03-20 00:12:42 UTC
Description of problem:
Occurs on boot of a Fedora 19 live image built from current repositories.
SELinux is preventing /usr/sbin/modem-manager from 'read' accesses on the file udev.conf.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that modem-manager should be allowed read access on the udev.conf file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep modem-manager /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:modemmanager_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:net_conf_t:s0
Target Objects                udev.conf [ file ]
Source                        modem-manager
Source Path                   /usr/sbin/modem-manager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-22.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.0-0.rc3.git0.3.fc19.x86_64 #1
                              SMP Mon Mar 18 21:39:31 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-03-19 19:39:23 EDT
Last Seen                     2013-03-19 19:39:23 EDT
Local ID                      92d68772-9f7e-4b27-a1df-08646df910b4

Raw Audit Messages
type=AVC msg=audit(1363736363.926:77): avc:  denied  { read } for  pid=743 comm="modem-manager" name="udev.conf" dev="dm-0" ino=151532 scontext=system_u:system_r:modemmanager_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:net_conf_t:s0 tclass=file


type=AVC msg=audit(1363736363.926:77): avc:  denied  { open } for  pid=743 comm="modem-manager" path="/etc/udev/udev.conf" dev="dm-0" ino=151532 scontext=system_u:system_r:modemmanager_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:net_conf_t:s0 tclass=file


Hash: modem-manager,modemmanager_t,net_conf_t,file,read

audit2allow

#============= modemmanager_t ==============
allow modemmanager_t net_conf_t:file { read open };

audit2allow -R
require {
	type modemmanager_t;
}

#============= modemmanager_t ==============
sysnet_read_config(modemmanager_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.0-0.rc3.git0.3.fc19.x86_64
type:           libreport

Comment 1 Adam Williamson 2013-03-20 00:12:55 UTC
Final blocker: "In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login"

Comment 2 Daniel Walsh 2013-03-20 00:38:50 UTC

*** This bug has been marked as a duplicate of bug 923497 ***


Note You need to log in before you can comment on or make changes to this bug.