Bug 923501 - gnome-initial-setup is not visible on first boot after install
gnome-initial-setup is not visible on first boot after install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Alpha/F19AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-03-19 20:56 EDT by Adam Williamson
Modified: 2013-03-22 21:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 21:54:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
journalctl from a system displaying the bug (546.26 KB, text/plain)
2013-03-20 12:08 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-03-19 20:56:49 EDT
I built a Fedora 19 live image from current repos, adding gnome-initial-setup-0.8-1.fc19.x86_64.rpm . GDM is gdm-3.7.91-1.fc19.x86_64 .

On first boot after install (with SELinux disabled - some SELinux borkage nerfs everything if you leave it enabled), I just see what looks like GDM with no users: a big dark grey rectangle with a panel at the top showing date, accessibility, and sound.

However, logs indicate that gnome-initial-setup is running; there are various messages from it in /var/log/messages and stuff. If I hit 'alt-tab', at least the first couple of times, I see a 'Initial Setup' icon in the alt-tab switcher.

So it looks like g-i-s is actually running, but it's somehow behind GDM? Just a guess.

This is in a virt-manager VM, with qxl/SPICE graphics. If I create a user at console and reboot, I still see the same blank grey screen - so what I'm seeing isn't exactly the GDM login screen, I guess.
Comment 1 Adam Williamson 2013-03-19 21:34:29 EDT
AlphaBlocker: "A system installed with a graphical package set must boot to the 'firstboot' utility on the first boot after installation. The firstboot utility must be able to create a working user account."

OK, we need to re-word that for initial-setup, but it's clearly breaching the spirit.
Comment 2 Adam Williamson 2013-03-20 04:46:26 EDT
I'm uploading my latest live image to assist in debugging this. It will be complete at:

http://fedorapeople.org/groups/qa/20130320-desktop-x86_64.iso

in approx. 50 minutes (it's currently there, but still uploading, so incomplete). sha256sum is:

38ffc3ca990f4d111f2e2e5c4a185358ef665f2bfaa9513b849102658a5e79d1
Comment 3 Colin Walters 2013-03-20 09:30:48 EDT
With this kind of stuff, the most useful is the journalctl output.
Comment 4 Adam Williamson 2013-03-20 11:57:26 EDT
oh, sorry, thought I'd attached them. Will do shortly.
Comment 5 Adam Williamson 2013-03-20 12:08:30 EDT
Created attachment 713305 [details]
journalctl from a system displaying the bug

GDM starts right around 12:00:07. I am in enforcing=0 , so the SELinux issues shouldn't be causing the problem, though obviously we'd want to fix them too.

The crash at 12:00:47 is me trying to fpaste this log and it being too big for the server's liking.

I'll file the eventual g-i-s crash (12:01:14) if I can get abrt to play ball.
Comment 6 Adam Williamson 2013-03-20 12:55:10 EDT
Discussed at 2013-03-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-03-20/f19alpha-blocker-review-2.2013-03-20-16.00.log.txt . Accepted as a blocker per criterion cited in comment #1: it's possible that this might not happen on bare metal, if that's the case, we'll re-visit it. But for now we're assuming it's a showstopper.
Comment 7 Adam Williamson 2013-03-20 13:18:58 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=923908 is my best effort at filing the crash.
Comment 8 Adam Williamson 2013-03-20 19:41:05 EDT
This patch from Jasper:

http://paste.fedoraproject.org/5658/13638161/

fixes this bug for me. However, the crash - https://bugzilla.redhat.com/show_bug.cgi?id=923908 - still happens: g-i-s runs for a while, then crashes. Also, the fourth panel of g-i-s - where you create a user - renders properly very very briefly (a split second), then the whole window just goes grey. I'll see if I can find any output specifically related to that.
Comment 9 Adam Williamson 2013-03-21 02:45:46 EDT
The latest build fixes this, I've tested it, just waiting a bit until it hits the public repos before closing.
Comment 10 Kamil Páral 2013-03-21 08:21:26 EDT
What's "the latest build"? I still see this problem with 0.8-3.
Comment 11 Kamil Páral 2013-03-21 12:25:30 EDT
This is verified with g-s-i 0.8-3 AND gnome-shell 3.97.2-2.
Comment 12 Adam Williamson 2013-03-22 21:54:26 EDT
Those are both in the repos now.

Note You need to log in before you can comment on or make changes to this bug.