Bug 923504 - crash in aci evaluation
Summary: crash in aci evaluation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks: 929115
TreeView+ depends on / blocked
 
Reported: 2013-03-20 01:24 UTC by Nathan Kinder
Modified: 2013-11-21 21:06 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-14.el6_4
Doc Type: Bug Fix
Doc Text:
Previously, a code in an Acl plug-in source code dereferenced a NULL pointer, and attempts to get effective rights on an entry that did not exit could have lead to an unexpected termination due to a segmentation fault. This update checks for NULL entry pointers and returns the appropriate error. Now, attempts to get effective rights on an entry that does not exit, no longer causes crashes, and the server returns the appropriate error message.
Clone Of:
Environment:
Last Closed: 2013-11-21 21:06:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
schema file to reproduce the issue (1.19 KB, text/x-ldif)
2013-03-27 19:49 UTC, mreynolds
no flags Details
entries needed to reproduce the issue (2.66 KB, text/x-ldif)
2013-03-27 19:50 UTC, mreynolds
no flags Details
ACI's needed to reproduce the issue (3.96 KB, text/x-ldif)
2013-03-27 19:57 UTC, mreynolds
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1653 normal SHIPPED_LIVE 389-ds-base bug fix update 2013-11-20 21:53:19 UTC

Description Nathan Kinder 2013-03-20 01:24:29 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/628

under specific conditions the server can crash when handling a getEffectiveRights request

Comment 3 mreynolds 2013-03-27 19:48:58 UTC
Steps to reproduce:

[1]  Stop the server, and copy 99user.ldif to /etc/dirsrv/slapd-INSTANCE/schema/
[2]  Start the server.
[3]  Use ldapmodify and add entries.ldif
[4]  Use ldapmodify and add acis.ldif
[5]  Run this ldapsearch:

ldapsearch -xLLL -p 389 -h localhost -D "cn=directory manager" -w secret123 -E '1.3.6.1.4.1.42.2.27.9.5.2=:dn:uid=sub-9999,ou=subscriber,ou=customer1,ou=oneview,ou=mmo,dc=example,dc=com' -b "dc=example,dc=com" "uid=sub-9999" shortCode


The server should not crash.

Comment 4 mreynolds 2013-03-27 19:49:35 UTC
Created attachment 717254 [details]
schema file to reproduce the issue

Comment 5 mreynolds 2013-03-27 19:50:21 UTC
Created attachment 717255 [details]
entries needed to reproduce the issue

Comment 6 mreynolds 2013-03-27 19:57:10 UTC
Created attachment 717257 [details]
ACI's needed to reproduce the issue

Comment 9 Ján Rusnačko 2013-06-10 13:31:55 UTC
acl/misc.sh

Comment 11 Ján Rusnačko 2013-08-22 12:54:23 UTC
Tested version 389-ds-base-1.2.11.15-22.el6.x86_64 : acl/misc tests passed 100%. Verified.

Comment 12 errata-xmlrpc 2013-11-21 21:06:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html


Note You need to log in before you can comment on or make changes to this bug.