Bug 92355 - redhat-control-network can't change profiles as user
Summary: redhat-control-network can't change profiles as user
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-05 13:01 UTC by István Tóth
Modified: 2007-04-18 16:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 12:45:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description István Tóth 2003-06-05 13:01:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
When, as a normail user I start the redhat-control-network app, I am not
prompted for root password. When I try to change the current profile, it fails,
and I can see that the program has insufficient permission to manipulate files
in /etc/sysconfig.

If I start the command as root, it works fine.

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1.log in as normal user
2.start redhat-control-netwrok
3.try to change profile
    

Actual Results:  The program refuses to change profiles, and the debug info
shows that it would need root priviliges to do it.

Expected Results:  It should prompt for root password, then change the profile
successfully.

Additional info:

I think the root of the problem is that redhat-control-network has some
functionality that should be accessible to normal users, and that is why it does
not ask for root password by default. 

However, the change profile operation does need root permission (and i belive it
should, too), but redhat-control-network is not smart enough to realize it.

I am filing it a Normail, instead of Low, beacuse even though it has a
workaround, it is probably not obvious to the casual users, that are targeted
with this snazzy tool.

Comment 1 Harald Hoyer 2003-06-05 13:22:11 UTC
please try the bugfix release on:
http://people.redhat.com/redhat-config-network

Comment 2 István Tóth 2003-06-05 15:46:29 UTC
I've tried it, but unfortunately it seems to have regressed. 

It asks for the root password, and runs with no errors.
It also replaces /etc/resolv.conf correctly.

However, it does not change the ifconfig data.

I've poked around, and it seems that while the shipping version links the
ifcfg-eth0_variant file from the profile as ifcfg-eth0 to
/etc/sysconfig/network-scripts, this new version does not change the name, and
links there as ifcfg-eth0_variant, and the ifup/ifdown scripts cannot handle this.



Comment 3 István Tóth 2004-02-27 12:45:12 UTC
As I no longer have a RH9 system ready to test it, I can only assume
that the issued update fixes the problem.

Closing bug.


Note You need to log in before you can comment on or make changes to this bug.