Bug 9239 - finger doesn't provide .plan info for remote requests
finger doesn't provide .plan info for remote requests
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: finger (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-08 14:23 EST by Brock Organ
Modified: 2016-10-27 13:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 09:47:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brock Organ 2000-02-08 14:23:18 EST
finger provides plan info (from .plan) for local finger request, but not
for networked requests ...


[root@test95 /root]# finger user1 Login: user1
Name: (null) Directory: /home/user1                  Shell: /bin/bash On
since Tue Feb  8 13:39 (EST) on pts/6 from test95    4 minutes 40 seconds
idle No mail. Plan:
here is some plan info ...
whatever...
[root@test95 /root]# finger user1@localhost
[test95.test.redhat.com] Login: user1                            Name:
(null) Directory: /home/user1                  Shell: /bin/bash On since
Tue Feb  8 13:39 (EST) on pts/6 from test95    4 minutes 44 seconds idle No
mail. No Plan.
[root@test95 /root]# finger user1@test95
[test95.test.redhat.com] Login: user1                            Name:
(null) Directory: /home/user1                  Shell: /bin/bash On since
Tue Feb  8 13:39 (EST) on pts/6 from test95    4 minutes 48 seconds idle No
mail. No Plan.
[root@test95 /root]# finger user1@test95.test.redhat.com
[test95.test.redhat.com] Login: user1                            Name:
(null) Directory: /home/user1                  Shell: /bin/bash On since
Tue Feb  8 13:39 (EST) on pts/6 from test95    4 minutes 52 seconds idle No
mail. No Plan. [root@test95
/root]#
Comment 1 Nalin Dahyabhai 2000-02-10 09:21:59 EST
The in.fingerd server executes without any special permissions, so what you're
seeing is probably a permissions problem on the user's .plan file, which isn't
set to be world-readable.
Comment 2 Nalin Dahyabhai 2000-02-10 09:47:59 EST
Problem was actually user home directory not flagged world-readable by default.
Comment 3 openshift-github-bot 2016-10-27 13:47:23 EDT
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/de8aca535f2762214184cd6bbc28d9948aac3a14
Merge pull request #749 from zherman0/bug9239

Merged by openshift-bot

Note You need to log in before you can comment on or make changes to this bug.