Bug 92413 - ItemResolver interface needs to handle caching correctly
Summary: ItemResolver interface needs to handle caching correctly
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bryan Che
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On: 91891
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-05 21:25 UTC by Scott Seago
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 15:41:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Seago 2003-06-05 21:25:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Recent addition of url-to-item caching to improve ItemResolver performance
breaks template contexts, since current implementations rely on side effects of
the Item resolution -- in particular the template context is parsed from the URL
and set as a request attribute.

Currently this is the first step of getItem -- calling a private method
"stripTemplateFromURL(String url)" which sets the request attribute. We should
do the following to solve this:

1) Add " String stripTemplateFromURL(String inURL);" to the ItemResolver interface
2) Modify any existing ItemResolver implementations (currently only
SimpleItemResolver and MultilingualItemResolver, soon to be joined by
CategoryItemResolverImpl) to implement the above method and remove any calls to
it in getItem()
3) ContentSectionServlet should call stripTemplateFromURL on the URL before
passing this to the ItemResolver, passing the modified URL to the ItemResolver
implementation (or before grabbing the Item from the cache)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Using cached item instead of calling ItemResolver doesn't set the
templateContext request attribute
2.
3.
    

Additional info:

Comment 1 Scott Seago 2003-06-05 21:26:15 UTC
Doesn't depend on all of 91891, but it depends on the
ItemResolver/TemplateResolver refactoring described there, as the current
MultilingualItemResolver doesn't handle Template contexts correctly

Comment 2 Bryan Che 2003-06-06 22:35:28 UTC
fixed at changelist 32132


Note You need to log in before you can comment on or make changes to this bug.