Bug 924138 - Cannot set password for root during text-mode installation
Cannot set password for root during text-mode installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
high Severity high
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
:
: 926900 (view as bug list)
Depends On:
Blocks: F19Alpha/F19AlphaBlocker fedora19rtt
  Show dependency treegraph
 
Reported: 2013-03-21 05:37 EDT by Jan Stodola
Modified: 2013-04-02 11:52 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-19.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-02 11:52:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (22.56 KB, image/png)
2013-03-21 05:37 EDT, Jan Stodola
no flags Details
anaconda.log (1.75 KB, text/plain)
2013-03-21 05:39 EDT, Jan Stodola
no flags Details
program.log (18.78 KB, text/plain)
2013-03-21 05:39 EDT, Jan Stodola
no flags Details
storage.log (71.17 KB, text/plain)
2013-03-21 05:39 EDT, Jan Stodola
no flags Details
syslog (66.47 KB, text/plain)
2013-03-21 05:39 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2013-03-21 05:37:45 EDT
Created attachment 713686 [details]
screenshot

Description of problem:
Anaconda running in text mode doesn't accept password for root, the password is written in on screen when typed. See attached screenshot.

Version-Release number of selected component (if applicable):
Fedora-19-Alpha-TC1
anaconda-19.12

How reproducible:
always

Steps to Reproduce:
1. Boot from Fedora-19-Alpha-TC1-x86_64-netinst.iso, add "text" to the kernel command line
2. try to enter password for root
  
Actual results:
Entered password is visible on screen and not accepted by anaconda.

Expected results:
Entered password is not visible, anaconda accepts valid password.

Additional info:
Comment 1 Jan Stodola 2013-03-21 05:39:36 EDT
Created attachment 713688 [details]
anaconda.log
Comment 2 Jan Stodola 2013-03-21 05:39:39 EDT
Created attachment 713689 [details]
program.log
Comment 3 Jan Stodola 2013-03-21 05:39:43 EDT
Created attachment 713690 [details]
storage.log
Comment 4 Jan Stodola 2013-03-21 05:39:50 EDT
Created attachment 713691 [details]
syslog
Comment 5 Martin Sivák 2013-03-21 10:12:30 EDT
The issue is a bit different here..

It was supposed to show you the password prompt first (Password: ). This looks like a situation where just the Spoke header was displayed but no input was requested by anaconda.
Comment 6 Martin Sivák 2013-03-22 05:57:10 EDT
This should be fixed in the next anaconda build.
Comment 7 Martin Sivák 2013-03-25 10:44:28 EDT
*** Bug 926900 has been marked as a duplicate of this bug. ***
Comment 8 Andre Robatino 2013-03-26 06:07:19 EDT
This is fixed in 19 Alpha TC2 (anaconda 19.13). BTW, I noticed in both TC1 and TC2 that in the "Create User" spoke, Fullname and Username have no prompt on the same line as the entered text. They work anyway, but it looks odd.
Comment 9 Jan Stodola 2013-03-26 08:27:02 EDT
Fixed in anaconda-19.13.

Moving to VERIFIED.
Comment 10 Adam Williamson 2013-04-02 11:52:06 EDT
If it's fixed in TC2/TC3, we can close it.

Note You need to log in before you can comment on or make changes to this bug.