This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 924200 - [xmlrpc_FlagType]Can create flagtype with invalid name via RPC
[xmlrpc_FlagType]Can create flagtype with invalid name via RPC
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
4.4
Unspecified Unspecified
high Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks: 822007
  Show dependency treegraph
 
Reported: 2013-03-21 07:01 EDT by Xin Zhang
Modified: 2014-10-12 18:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-16 02:01:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Simon Green 2013-03-21 07:08:49 EDT
(In reply to comment #0)
> Steps to Reproduce:
> 1.Login with user who is in "editusers" group.
> 2.Passing an existing name and proper description to this call.
>   
> Expected results:
> Cann't create successfully.

It is perfectly legal to create two different flag types with the same name.
Comment 2 Roman Joost 2013-03-24 23:48:22 EDT
Hi Xin,

would it be possible to add the calls to this report to reproduce this easier? Either as a comment or preferable as an attachment.

Thanks a lot!
Comment 3 Xin Zhang 2013-03-25 02:07:46 EDT
(In reply to comment #2)
> Hi Xin,
> 
> would it be possible to add the calls to this report to reproduce this
> easier? Either as a comment or preferable as an attachment.
> 
> Thanks a lot!

Sure,for example,

>>> xmlrpc.FlagType.create({'name':[123456],'description':'for a test'})
    Return:{'id': 534}

    In actually,array is invalid name,the name should be a string.So it should return related error info.

Thank you.
Comment 4 Simon Green 2013-04-16 02:01:53 EDT
Like the other RPC issue reported, this is not something that I think we need to fix, especially since only people with the proper privilege can use this RPC call.

Note You need to log in before you can comment on or make changes to this bug.