Bug 924399 - cgrulesengd daemon has different default logging level than the rest of the library
Summary: cgrulesengd daemon has different default logging level than the rest of the l...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup
Version: 6.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-21 17:18 UTC by Peter Schiffer
Modified: 2013-11-21 22:33 UTC (History)
4 users (show)

(edit)
Cause: cgrulesengd daemon had different default logging level than the rest of the library

Consequence: inconsistent log messages

Fix: unify logging level of cgrulesengd daemon and library

Result: unified log messages
Clone Of:
(edit)
Last Closed: 2013-11-21 22:33:00 UTC


Attachments (Terms of Use)
libcgroup-0.37-cgrulesengd-logging.patch (3.89 KB, patch)
2013-07-31 15:55 UTC, Peter Schiffer
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1685 normal SHIPPED_LIVE libcgroup bug fix and enhancement update 2013-11-20 21:52:29 UTC

Description Peter Schiffer 2013-03-21 17:18:25 UTC
Description of problem:
cgrulesengd daemon has different logging level settings than the rest of the library which are not in sync

Version-Release number of selected component (if applicable):
libcgroup-0.37-7.1.el6_4

How reproducible:
always

Steps to Reproduce:
1. run cgconfig and cgred service
2. see /var/log/messages
3.
  
Actual results:
many warning messages in /var/log/messages from cgrulesengd daemon

Expected results:
only errors in /var/log/messages from cgrulesengd daemon

Additional info:
patch posted in upstream:
http://www.mail-archive.com/libcg-devel@lists.sourceforge.net/msg03752.html

Comment 6 Peter Schiffer 2013-07-31 15:55:15 UTC
Created attachment 781225 [details]
libcgroup-0.37-cgrulesengd-logging.patch

Comment 9 Mike Gahagan 2013-09-19 19:51:43 UTC
confirmed cgrulesengd from libcgroup-0.40.rc1-3.el6 now has default log level for errors rather than warnings.

Comment 10 errata-xmlrpc 2013-11-21 22:33:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1685.html


Note You need to log in before you can comment on or make changes to this bug.