Bug 924406 - Shaded (rolled-up) windows leave their shadow decorations in place.
Summary: Shaded (rolled-up) windows leave their shadow decorations in place.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-21 17:46 UTC by Matthew Miller
Modified: 2013-06-12 17:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-12 17:56:18 UTC


Attachments (Terms of Use)

Description Matthew Miller 2013-03-21 17:46:53 UTC
Description of problem:

I have "Togggle Shade" as the action on title bar double click. Now when I do this, the rectangle of the window's shadow is left in place, with a smaller transparent rectangle inside.

Version-Release number of selected component (if applicable):

gnome-shell-3.7.92-1.fc19.x86_64


How reproducible:

Always

Steps to Reproduce:
1. Turn on toggle shade (using gnome-tweak-tool or otherwise)
2. Double-click on a title bar
  
Actual results:

Weird decoration behavior as described above

Expected results:

Window "rolls up" into the title bar, leaving only that visible.

Additional info:

I love the window shade feature, since unlike minimized windows, they stay in roughly the same position so my spacial memory is still useful in unhiding them.

Comment 1 Matthew Miller 2013-04-05 14:04:59 UTC
I think this is probably actually a mutter bug. 

Happening with 3.8.0-1.

Comment 2 Matthew Miller 2013-04-05 20:16:13 UTC
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=693714

Comment 3 Matthew Miller 2013-06-12 17:56:18 UTC
Confirmed fixed with mutter-3.8.3-1.fc19.x86_64


Note You need to log in before you can comment on or make changes to this bug.