Bug 924507 - f19 cannot boot in basic video mode with RADEON EVERGREEN REDWOOD (vesa: Ignoring device with a bound kernel driver)
Summary: f19 cannot boot in basic video mode with RADEON EVERGREEN REDWOOD (vesa: Igno...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 966614 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-21 22:42 UTC by Reartes Guillermo
Modified: 2013-05-28 11:08 UTC (History)
3 users (show)

Fixed In Version: kernel-3.9.3-301.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-24 20:47:02 UTC


Attachments (Terms of Use)
syslog file (110.21 KB, text/plain)
2013-03-21 22:42 UTC, Reartes Guillermo
no flags Details
X.log (5.51 KB, text/plain)
2013-03-21 22:43 UTC, Reartes Guillermo
no flags Details
anaconda.log (673 bytes, text/plain)
2013-03-21 22:43 UTC, Reartes Guillermo
no flags Details
program.log (1.15 KB, text/plain)
2013-03-21 22:44 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2013-03-21 22:42:59 UTC
Created attachment 714144 [details]
syslog file

Description of problem:

It is not possible to boot with the option TROUBLESHOOTING ->
INSTALL Fedora 19-xx in basic video mode.

If somebody has a video issue, this is the next option to try and it will not work. Luckily the system can be booted without it.

I believe since kms is in use, vesa cannot use the device, or something like that. Or it might be a bug.

Version-Release number of selected component (if applicable):
F19a TC1 (anaconda 19.12)

How reproducible:
always

Steps to Reproduce:
1. boot with the basic video option
2. xorg does not start, vnc or text mode are offered instead.
  
Actual results:
no graphics mode. 

Expected results:
basic video, if that is possible.

Additional info:

* Radeon HD5670 on a M4N72-E (Phenonm II)

Comment 1 Reartes Guillermo 2013-03-21 22:43:29 UTC
Created attachment 714145 [details]
X.log

Comment 2 Reartes Guillermo 2013-03-21 22:43:46 UTC
Created attachment 714146 [details]
anaconda.log

Comment 3 Reartes Guillermo 2013-03-21 22:44:14 UTC
Created attachment 714147 [details]
program.log

Comment 4 Reartes Guillermo 2013-03-21 23:13:01 UTC
Idem another system with a CAICOS card, either in BIOS or UEFI.

Command line: BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2019-Alpha-TC1\x20x86_64 xdriver=vesa nomodeset quiet

Comment 5 Reartes Guillermo 2013-04-04 22:02:25 UTC
This is still an issue with TC4 (19.15).

Currently, normal video has an issue and vnc also has an issue. 
Text mode is limited in functionality.

Basic Video or VESA as a working troubleshooting option would be useful. 


[    38.923] Loading extension GLX
[    38.923] (II) LoadModule: "vesa"
[    38.926] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    38.940] (II) Module vesa: vendor="X.Org Foundation"
[    38.940]    compiled for 1.14.0, module version = 2.3.2
[    38.940]    Module class: X.Org Video Driver
[    38.940]    ABI class: X.Org Video Driver, version 14.1
[    38.940] (II) VESA: driver for VESA chipsets: vesa
[    38.940] (++) using VT number 7

[    38.982] vesa: Ignoring device with a bound kernel driver
[    38.982] (WW) Falling back to old probe method for vesa
[    38.984] (EE) Screen 0 deleted because of no matching config section.
[    38.984] (II) UnloadModule: "vesa"
[    38.984] (EE) Device(s) detected, but none match those in the config file.
[    38.984] 
Fatal server error:
[    38.984] no screens found
[    38.984] (EE) 
Please consult the Fedora Project support 
         at http://wiki.x.org
 for help. 
[    38.984] (EE) Please also check the log file at "/tmp/X.log" for additional information.
[    38.984] (EE) 
[    39.038] Server terminated with error (1). Closing log file.

Comment 6 Dave Airlie 2013-05-15 01:36:20 UTC
I've pushed a fix for the next F19 kernel to pick up that should restore nomodeset working.

Thanks for report.

Comment 7 Fedora Update System 2013-05-20 16:21:18 UTC
kernel-3.9.3-301.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.9.3-301.fc19

Comment 8 Fedora Update System 2013-05-20 20:06:36 UTC
Package kernel-3.9.3-301.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.9.3-301.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8639/kernel-3.9.3-301.fc19
then log in and leave karma (feedback).

Comment 9 Jan Kratochvil 2013-05-24 07:27:01 UTC
*** Bug 966614 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2013-05-24 20:47:02 UTC
kernel-3.9.3-301.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Jan Kratochvil 2013-05-28 11:08:39 UTC
Confirming ATI RV710 [Radeon HD 4350] nomodeset works again:
PASS: kernel-3.8.11-200.fc18.x86_64
FAIL: kernel-3.9.2-200.fc18.x86_64
PASS: kernel-3.9.4-200.fc18.x86_64


Note You need to log in before you can comment on or make changes to this bug.