Bug 924515 - [abrt] libreoffice-core-3.6.5.2-2.fc18: SdrMarkView::CheckMarked(): Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] libreoffice-core-3.6.5.2-2.fc18: SdrMarkView::CheckMarked(): Process /...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:04aec21f28595ae32197a5272b5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-22 00:11 UTC by Matthew Garrett
Modified: 2013-04-20 01:09 UTC (History)
6 users (show)

Fixed In Version: libreoffice-3.6.6.2-3.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-20 01:09:19 UTC


Attachments (Terms of Use)
File: backtrace (44.77 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: build_ids (8.57 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: cgroup (128 bytes, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: core_backtrace (5.90 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: dso_list (22.64 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: environ (1.69 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: limits (1.29 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: maps (107.56 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: open_fds (579 bytes, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: proc_pid_status (934 bytes, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: smolt_data (2.75 KB, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details
File: var_log_messages (343 bytes, text/plain)
2013-03-22 00:11 UTC, Matthew Garrett
no flags Details

Description Matthew Garrett 2013-03-22 00:11:01 UTC
Version-Release number of selected component:
libreoffice-core-3.6.5.2-2.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress --splash-pipe=6
crash_function: SdrMarkView::CheckMarked()
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.7.9-201.fc18.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 SdrMarkView::CheckMarked() at /usr/lib64/libreoffice/program/../program/libsvxcorelo.so
 #1 SdrMarkView::AdjustMarkHdl() at /usr/lib64/libreoffice/program/../program/libsvxcorelo.so
 #2 SdrObjEditView::SdrEndTextEdit(unsigned char) at /usr/lib64/libreoffice/program/../program/libsvxcorelo.so
 #3 sd::View::SdrEndTextEdit(unsigned char) at /usr/lib64/libreoffice/program/../program/libsdlo.so
 #4 sd::ViewShellManager::Implementation::Deactivate(SfxShell*) at /usr/lib64/libreoffice/program/../program/libsdlo.so
 #5 sd::ViewShellManager::Implementation::TakeShellsFromStack(SfxShell const*) at /usr/lib64/libreoffice/program/../program/libsdlo.so
 #6 sd::ViewShellManager::Implementation::MoveToTop(SfxShell const&) at /usr/lib64/libreoffice/program/../program/libsdlo.so
 #7 sd::ViewShellManager::Implementation::WindowEventHandler(VclWindowEvent*) at /usr/lib64/libreoffice/program/../program/libsdlo.so
 #8 VclEventListeners::Call(VclSimpleEvent*) const at /usr/lib64/libreoffice/program/libvcllo.so
 #9 Window::CallEventListeners(unsigned long, void*) at /usr/lib64/libreoffice/program/libvcllo.so

Comment 1 Matthew Garrett 2013-03-22 00:11:07 UTC
Created attachment 714172 [details]
File: backtrace

Comment 2 Matthew Garrett 2013-03-22 00:11:09 UTC
Created attachment 714173 [details]
File: build_ids

Comment 3 Matthew Garrett 2013-03-22 00:11:12 UTC
Created attachment 714174 [details]
File: cgroup

Comment 4 Matthew Garrett 2013-03-22 00:11:14 UTC
Created attachment 714175 [details]
File: core_backtrace

Comment 5 Matthew Garrett 2013-03-22 00:11:16 UTC
Created attachment 714176 [details]
File: dso_list

Comment 6 Matthew Garrett 2013-03-22 00:11:18 UTC
Created attachment 714177 [details]
File: environ

Comment 7 Matthew Garrett 2013-03-22 00:11:22 UTC
Created attachment 714178 [details]
File: limits

Comment 8 Matthew Garrett 2013-03-22 00:11:25 UTC
Created attachment 714179 [details]
File: maps

Comment 9 Matthew Garrett 2013-03-22 00:11:28 UTC
Created attachment 714180 [details]
File: open_fds

Comment 10 Matthew Garrett 2013-03-22 00:11:29 UTC
Created attachment 714181 [details]
File: proc_pid_status

Comment 11 Matthew Garrett 2013-03-22 00:11:32 UTC
Created attachment 714182 [details]
File: smolt_data

Comment 12 Matthew Garrett 2013-03-22 00:11:34 UTC
Created attachment 714183 [details]
File: var_log_messages

Comment 13 David Tardon 2013-03-25 12:55:47 UTC
The backtrace is useless (again; this seems to be the rule lately?) Is the crash reproducible?

Comment 14 Matthew Garrett 2013-03-25 14:28:33 UTC
Nope. I'd entered some text as a bullet point list, then changed the slide type to centred text. The bullet point was still present. I tried deleting it and then shortly afterwards it crashed. I haven't been able to reproduce.

Comment 15 David Tardon 2013-03-25 15:58:37 UTC
Better than nothing, I guess... At least it is worth checking under valgrind. Thanks!

Comment 16 Caolan McNamara 2013-04-16 11:43:56 UTC
digging around I do get an uninitialized valgrind warning, which I had already fixed quite a while ago for 4-0 http://cgit.freedesktop.org/libreoffice/core/commit/?id=7093b2418d036b47ed706464956f330cfb89707a

Its plausible as a root cause of this, I'll backport to 3-6 and spin an update.

Comment 17 Fedora Update System 2013-04-16 19:08:44 UTC
libreoffice-3.6.6.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libreoffice-3.6.6.2-3.fc18

Comment 18 Fedora Update System 2013-04-18 02:48:28 UTC
Package libreoffice-3.6.6.2-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.6.6.2-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5966/libreoffice-3.6.6.2-3.fc18
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2013-04-20 01:09:21 UTC
libreoffice-3.6.6.2-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.