Bug 92452 - rpm hangs when trying to uninstall mozilla-mail
rpm hangs when trying to uninstall mozilla-mail
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
athlon Linux
high Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-06 09:18 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 14:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-06-06 09:18:38 EDT
Description of problem:
when I give the command "rpm -e mozilla-mail"
it waits forever. Recently, I installed
eclipse (2.1 Community Edition from IBM)
and I updated the kernel, my system is up-to-date.
(I can see the blue check on the toolbar)

When I ran mozilla from command line or from
the toolbar, it would wait a bit and then do
nothing, removing "starting mozilla" button on
the toolbar as well. To workaround the problem,
I wanted to uninstall mozilla and install it 
again. But there were 2 dependencies, mozilla-mail
and mozilla-psm. I ran the add/remove package
tool and unclicked the 3 applications (mozilla,
mozilla-mail and mozilla-psm, hence no mozilla
applications were clicked). Then, I pressed "update"
button and it hanged. I tried to reboot from the GNOME
controls, but it didn't work, I had to reboot the machine
by hand (press the power button of the computer).

I started linux again and logged in. I inserted the redhat 9 CD and clicked 
mozilla-mail to install it. It said it was already installed,
and the same happened for mozilla-psm and mozilla. 
However, the toolbar mozilla icon was not working, it was replaced 
with a gnome icon (foot picture on it). When clicking this icon,
it says can't find application mozilla.

So, I decided to try "rpm -e mozilla-mail", but it hanged too.
I had to kill the process as root. I also tried "rpm -q -i mozilla-mail" but 
that also hanged.

I don't know what to do to have mozilla working again.

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1.(possibly) install Eclipse 2.1 community edition (from eclipse.org)
2.update to the latest kernel (as of May 6, 2003)
3.try to uninstall mozilla
    
    
Actual results:


Expected results:


Additional info:
Comment 1 stuart boreen 2003-06-07 22:52:11 EDT
I've had a lot of rpm problems on a laptop I upgraded from 8 to 9. I get hangs
doing rpm -e and I need to kill -9 the process. The process will show <1 sec of
cpu time. If I go to /var/lib/rpm and erase the __db.* files and do an rpm
--initdb I can get things to work again.
I note this is a laptop that is not run 24/7. Once when I was getting the rpm -e
hang I noticed that the cron.daily rpm script was running too. Could this be
part of the problem.
My laptop is fully up2date with errata as of june 7
Comment 2 Jeff Johnson 2003-06-24 15:51:28 EDT
Do
    rm -rf /var/lib/rpm/__db*
    rpm -qa | grep mozilla
to see what mozilla packages you have installed.

Fore each installed mozilla package, verify that
files are actually there by doing (replace moz1, moz2,
... as appropriate)
    rpm -V moz1 moz2

If the verify reports damage, erase and reinstall (replace
moz1 as appropriate):
    rpm -e moz1
    rpm -Uvh moz1*.rpm

Does that get mozilla functioning?
Comment 3 Jeremy Katz 2005-04-19 14:43:51 EDT
Closing due to inactivity.  If this issue still occurs with current releases,
please reopen and set the release in which you've encountered the problem.

Note You need to log in before you can comment on or make changes to this bug.