Bug 924542 - Remove support of the source host from the HBAC on the server side both from UI and CLI
Summary: Remove support of the source host from the HBAC on the server side both from ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks: 960054 924775 947900 970460
TreeView+ depends on / blocked
 
Reported: 2013-03-22 02:53 UTC by Dmitri Pal
Modified: 2018-12-06 14:59 UTC (History)
5 users (show)

Fixed In Version: ipa-3.0.0-31.el6
Doc Type: Bug Fix
Doc Text:
Cause: Identity Management Host Based Access Control (HBAC) rules API still allowed administrators to specify a Source Host component of HBAC rules even though this component was deprecated. Consequence: Administrators may see unexpected behavior when using the Source Host component in HBAC rules. Fix: The IdM API no longer allows Source Host component in HBAC rules. Result: HBAC rules in IdM now contains only supported components and thus prevents unexpected behavior of the rules for administrators.
Clone Of:
: 924775 947900 970460 (view as bug list)
Environment:
Last Closed: 2013-11-21 20:52:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1651 0 normal SHIPPED_LIVE ipa bug fix and enhancement update 2013-11-21 00:39:40 UTC

Description Dmitri Pal 2013-03-22 02:53:55 UTC
The original set of requirements for IPA and SSSD included the requirement to factor in the source host of the connection in the hoist based access control decisions. Unfortunately the actual implementation showed that it can't be done reliably because source host information is not consistently passed through the stack to the component that needs to make a decision. As a result the implementation suffered failures that were hard to troubleshoot and/or avoid. As a result the client side SSSD made a decision to deprecate the support of source host. However the server side - IPA still allows defining rules that include source host. 

This bug calls for deprecation/removal of the support of the source host in IPA, both in UI and CLI. It is very confusing and should be removed as soon as possible.

Comment 1 Martin Kosek 2013-03-22 08:56:50 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3528

Comment 3 Rob Crittenden 2013-04-12 18:33:11 UTC
Fixed upstream

master:
b8b573a966f4be268031ccca5abce09767928ff7
d03255571c9d4c81d92c692fd0b6db6539856cf8
39982f6696267706b70f598ee80ce87924cc34a4

ipa-3-1:
0d5e310231962fb10a5396477bbcd2ce99b4e544
592db35c87ea8eee0f28b87c12dd889fead98701
e7954e267282fc4fa61aa004da5489fe42763a3a

Comment 12 errata-xmlrpc 2013-11-21 20:52:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1651.html


Note You need to log in before you can comment on or make changes to this bug.