Bug 924562 - Deployment restart caused by dependency replacement does not work
Summary: Deployment restart caused by dependency replacement does not work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Server
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR0
: EAP 6.3.0
Assignee: Stuart Douglas
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1282881
TreeView+ depends on / blocked
 
Reported: 2013-03-22 04:37 UTC by Stuart Douglas
Modified: 2018-12-06 14:59 UTC (History)
5 users (show)

(edit)
An issue that could result in a NullPointerException has been resolved in this release of JBoss EAP 6. The exception could present when a deployment partially restarted some data structures that were required have already been cleaned up to save memory (for example, when a dependency was replaced). This issue would prevent the redeployment from completing. To address this issue, partial redeployments are no longer allowed in this release of the product. If a dependency is replaced the deployment is now completely restarted and the exception no longer presents.
Clone Of:
(edit)
Last Closed: 2014-06-28 15:44:13 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker AS7-6761 Major Closed Deployment replace causes invalid state in DUP 2018-05-25 15:30 UTC
JBoss Issue Tracker WFLY-1363 Major Closed Updating deployment with dependant 2018-05-25 15:30 UTC
JBoss Issue Tracker WFLY-975 Major Closed Deployment replace causes invalid state in DUP 2018-05-25 15:30 UTC

Description Stuart Douglas 2013-03-22 04:37:36 UTC
If you have a deployment that dependends on another deployment (either using inter deployment dependencies or a class loading dependency) and you replace the dependee deployment then the dependent deployment will fail to restart.

Comment 1 JBoss JIRA Server 2013-03-26 01:25:33 UTC
Stuart Douglas <stuart.w.douglas@gmail.com> made a comment on jira AS7-6761

This is now resolved for non OSGi deployments. At the moment I can't see any way to achieve the desired OSGI behaviour without a redesign of how DUP's work.

Comment 2 JBoss JIRA Server 2013-03-28 19:57:41 UTC
Brian Stansberry <brian.stansberry@redhat.com> made a comment on jira AS7-6761

I'm moving this out of "Pull Request Sent" status but not to "Resolved" because AIUI the fix did not fully resolve the reported issue. I'll leave it to you guys to sort out what the next step is.

Comment 3 Stuart Douglas 2013-03-29 21:28:59 UTC
This is resolved for non-OSGi deployments. I think we should resolve this issue and create a new one for the OSGi problems, as the OSGi issue is not so much caused by dependency changes but rather by explicit start/stop operations on the bundle.

Comment 6 Michal Karm Babacek 2014-02-28 20:01:05 UTC
In SessionTest/WEB-INF/jboss-deployment-structure.xml 
<jboss-deployment-structure>
   <deployment>
      <dependencies>
         <module name="deployment.clusterbench.war" />
      </dependencies>
   </deployment>
</jboss-deployment-structure>

Deployed "SessionTest.war"
Deployed "clusterbench.war"

touch standalone/deployments/clusterbench.war

Triggers in EAP 6.3:

Unregister web context: /clusterbench
Unregister web context: /SessionTest
+++
Deployment restart detected for deployment SessionTest.war, performing full redeploy instead.
+++
Register web context: /clusterbench
Register web context: /SessionTest

Triggers in EAP 6.2:

MSC000001: Failed to start service jboss.deployment.unit."SessionTest.war".FIRST_MODULE_USE: 



VERIFIED

Comment 7 Scott Mumford 2014-04-23 05:37:53 UTC
Reformatted docs text and marked for inclusion in 6.3.0 Release Notes.

Comment 8 JBoss JIRA Server 2015-11-17 18:12:54 UTC
Brad Maxwell <bmaxwell@redhat.com> updated the status of jira WFLY-1363 to Resolved


Note You need to log in before you can comment on or make changes to this bug.