Bug 924577 - Mouse clicking doesn't work on Save Screenshot dialog after open it by Alt+S+P.
Summary: Mouse clicking doesn't work on Save Screenshot dialog after open it by Alt+S+P.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 924582
TreeView+ depends on / blocked
 
Reported: 2013-03-22 06:28 UTC by hyao@redhat.com
Modified: 2018-12-02 18:27 UTC (History)
12 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Press Alt+S (or other menu accelerators). Consequence: The guest keep Alt state pressed, and some guest functionality may not work correctly. Fix: Releasing the guest keys when the keyboard grab is taken in client UI. Result: Avoid sticky modifiers keys in the guest when using Gtk menu accelerators, or when loosing the grab.
Clone Of:
: 924582 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:08:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
debug file (3.58 KB, text/plain)
2013-03-22 06:28 UTC, hyao@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description hyao@redhat.com 2013-03-22 06:28:57 UTC
Created attachment 714321 [details]
debug file

Description of problem:
Mouse clicking doesn't work on Save Screenshot dialog after open it by Alt+S+P.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-18.el6_4.2
spice-server-0.12.0-12.el6.x86_64
spice-vdagent-0.12.0-4.el6_4.1
libvirt-0.10.2-18.el6_4.2
kernel-2.6.32-358.2.1.el6.x86_64
qemu-kvm-0.12.1.2-2.356.el6_4.2

How reproducible:
100%

Steps to Reproduce:
There is running guest on the host.
#virsh list --all
      Id Name State
      ----------------------------------------------------
      13 rhel63 running

1.Guest is opened via virt-viewer.
#virt-viewer rhel63

2.Press Alt+S on the key board.
Send key menu is open

3. Press P to PrintScreen.
Save Screenshot dialog opens in the guest. Use the mouse to click Save button

Actual result:
Nothing happen and can't save the screenshot.
PS. Mouse clicking on the opened Screenshot dialog doesn't work on other buttons, Help Copy to Clipboard, Cancel, Save and Close Window.

Expected result:
The screen shot is saved on the guest desktop.

Additional info:

Comment 1 Marc-Andre Lureau 2013-05-08 16:05:01 UTC
the problem is that while accessing the menu via keyboad, the Alt key is pressed, so the guest receives alt+print and doesn't do what you want. And worse, the Alt key stay pressed, so further mouse interactions will be affected (will move windows, like if you do alt+drag etc.)

Comment 2 Marc-Andre Lureau 2013-05-09 13:26:57 UTC
sent proposed fix to ML:
http://lists.freedesktop.org/archives/spice-devel/2013-May/013351.html

Comment 8 CongDong 2013-07-05 09:21:37 UTC
I can reproduce this bug:
Version:
virt-viewer-0.5.2-18.el6_4.2
spice-gtk-0.14-7.el6.x86_64

Steps:
1.Guest is opened via virt-viewer.
#virt-viewer $guest

2.Press Alt+S on the key board.
Send key menu is open

3. Press P to PrintScreen.
Save Screenshot dialog opens in the guest. Use the mouse to click Save button

Result:
Nothing happen and can't save the screenshot.

Verify:
Version:
virt-viewer-0.5.6-1.el6
spice-gtk-0.20-2.el6.x86_64

Setps:
As the steps above

Result:
After send key , ervery button can work well

Comment 9 errata-xmlrpc 2013-11-21 08:08:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.