Bug 924699 - SELinux is preventing /usr/libexec/gdm-session-worker from 'write' accesses on the file .pwd.lock.
SELinux is preventing /usr/libexec/gdm-session-worker from 'write' accesses o...
Status: CLOSED DUPLICATE of bug 924708
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ac00bbc1906305ec7e4d87577a0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-22 07:01 EDT by Jan Sedlák
Modified: 2013-03-22 09:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 09:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2013-03-22 07:01:05 EDT
Description of problem:
Logged in using new user account.
SELinux is preventing /usr/libexec/gdm-session-worker from 'write' accesses on the file .pwd.lock.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gdm-session-worker should be allowed write access on the .pwd.lock file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gdm-session-wor /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:passwd_file_t:s0
Target Objects                .pwd.lock [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-3.7.92-2.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-23.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.0-0.rc3.git0.5.fc20.x86_64 #1
                              SMP Tue Mar 19 01:25:41 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-03-22 06:54:49 EDT
Last Seen                     2013-03-22 06:54:49 EDT
Local ID                      6faaf194-c08d-4692-bbb8-63c2a444ce1b

Raw Audit Messages
type=AVC msg=audit(1363949689.844:319): avc:  denied  { write } for  pid=2605 comm="gdm-session-wor" name=".pwd.lock" dev="dm-0" ino=144564 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:passwd_file_t:s0 tclass=file


type=SYSCALL msg=audit(1363949689.844:319): arch=x86_64 syscall=open success=yes exit=EACCES a0=7f93061fa27f a1=80041 a2=180 a3=30633a30732d3073 items=0 ppid=2522 pid=2605 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=gdm-session-wor exe=/usr/libexec/gdm-session-worker subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: gdm-session-wor,xdm_t,passwd_file_t,file,write

audit2allow

#============= xdm_t ==============
allow xdm_t passwd_file_t:file write;

audit2allow -R
require {
	type xdm_t;
}

#============= xdm_t ==============
auth_manage_passwd(xdm_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.0-0.rc3.git0.5.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-03-22 09:29:24 EDT

*** This bug has been marked as a duplicate of bug 924708 ***

Note You need to log in before you can comment on or make changes to this bug.