Bug 924839 - Capture output of makedumpfile --dump-dmesg for available vmcores
Summary: Capture output of makedumpfile --dump-dmesg for available vmcores
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryn M. Reeves
QA Contact: Filip Holec
URL:
Whiteboard:
Depends On:
Blocks: 1026959
TreeView+ depends on / blocked
 
Reported: 2013-03-22 15:36 UTC by Bryn M. Reeves
Modified: 2016-04-18 10:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: The sosreport command will now collect kernel log data (dmesg) from any vmcore crash dump images found on the running system. Reason: The kernel log may contain important diagnostics indicating the cause of a previous system crash. Result (if any): Logs from any present vmcore images are now available in reports for diagnostic purposes.
Clone Of:
: 1026959 (view as bug list)
Environment:
Last Closed: 2013-11-21 22:38:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1688 normal SHIPPED_LIVE sos bug fix and enhancement update 2013-11-21 00:39:30 UTC

Description Bryn M. Reeves 2013-03-22 15:36:24 UTC
Description of problem:
The makedumpfile command has the ability to extract the dmesg buffer from a saved kernel dump (vmcore) file.

Often the oops, panic and other messages logged are all that are required to match an instance with a known problem, or to support initial first-fault debugging.

Capturing this data in sos avoids the need for further round trips to collect it manually.

E.g.:

  # makedumpfile  --dump-dmesg vmcore dmesg

  The dmesg log is saved to dmesg.

RHEL6 kernels include the VMCOREINFO section in the dump file so there is no need for additional debuginfo.


Version-Release number of selected component (if applicable):
2.2-*.el6

How reproducible:
100%

Steps to Reproduce:
1. sosreport
2. tar xf $report
3. ls $report_path/sos_commands/kernel
  
Actual results:
No saved dmesg files.

Expected results:
Saved dmesg files with a named based on the name of the dump file from which it was generated.

Additional info:

Comment 6 Bryn M. Reeves 2013-11-05 17:57:12 UTC
commit 04d4e4145d695232ba7f7e0a4dd539b39de1dc8b
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Tue Aug 13 18:46:47 2013 +0100

    Collect saved vmcore-dmesg.txt files in kdump plug-in
    
    Recent versions of kexec-utils automatically generate a text
    file containing the dmesg buffer of the captured vmcore.
    
    This is useful for first-fault debugging and should be included.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>

Comment 8 errata-xmlrpc 2013-11-21 22:38:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1688.html


Note You need to log in before you can comment on or make changes to this bug.