Bug 9251 - mkfontdir does not work
mkfontdir does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-08 17:48 EST by Fritz Elfert
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 15:09:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for fixing bug #9251 (370 bytes, patch)
2000-02-08 17:51 EST, Fritz Elfert
no flags Details | Diff

  None (edit)
Description Fritz Elfert 2000-02-08 17:48:23 EST
mkfontdir in your current distribution is broken due to your "xfsftfontdir"
patch. (patch #22 in .src.rpm). The directory argument is never evaluated,
and therefore no font.dir is created. Here is a patch for that.
Hope, the bugzilla web-interface clobbers it too much:

--- XFree86-3.3.5-orig/xc/programs/mkfontdir/mkfontdir.c        Tue Feb  8
23:38:16 2000
+++ XFree86-3.3.5/xc/programs/mkfontdir/mkfontdir.c     Tue Feb  8 23:21:37
200
@@ -761,7 +761,7 @@
       for(encoding=encodings[i]; encoding; encoding=encoding->next)
         count++;
-    if (argc == argc)
+    if (argn == argc)
     {
        if (!DoDirectory(".", encodings, count))
        {
Comment 1 Fritz Elfert 2000-02-08 17:51:59 EST
Created attachment 102 [details]
patch for fixing bug #9251
Comment 2 Preston Brown 2000-02-10 15:09:59 EST
fixed in XFree86-3.3.6-12 and later.

Note You need to log in before you can comment on or make changes to this bug.