Bug 9253 - debugging core files fails.
Summary: debugging core files fails.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdb   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-08 23:01 UTC by Hans de Goede
Modified: 2016-12-02 18:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-09 08:39:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch replacing the fpregset patch, fixing the described problems (2.45 KB, patch)
2000-02-08 23:01 UTC, Hans de Goede
no flags Details | Diff

Description Hans de Goede 2000-02-08 23:01:09 UTC
Jakub Jelinek wrote:
>
> On Tue, Feb 08, 2000 at 04:20:50PM +0100, Hans de Goede wrote:
> > Hi,
> >
> > I was doing some development on xmame for a change, and the new version
> > happens to dump core on me whenever it likes (and it seems to like todo
> > it often).
> >
> > My problem is that when I try to run gdb on the core file what I get
> > is:
> > Core was generated by `./test'.
> > Program terminated with signal 11, Segmentation fault.
> >
> > warning: wrong size gregset struct in core file
> > Reading symbols from /lib/libc.so.6...done.
> > Reading symbols from /lib/ld-linux.so.2...done.
> >
> > warning: wrong size gregset struct in core file
> > #0  0x0 in ?? ()
> > (gdb)
>
> Can be easily fixed by using elf_gregset_t instead of gregset_t in
> i386-linux-nat.c.
> Jim, will you take care of this or should I do it?
>
Thanks for the hint,
this doesn't fix it however, gregset_t and fpregset_t are also used in
the generic file core-regset.c
I'm now buidling with them changed to elf_Xregset too.

If this works I'll send a patch over the list, and bugzilla it.

---

Okay, the patch works, here is the bugzilla entry. The patch attached
replaces the fpregset patch, it is a generic regset patch fixing other
regset problems too.

It might be worth it todo one more check for regset_t 's and replace all
these by elf_regset_t's. I did this, but maybe I overlooked something,
anyways this one works for me.

Comment 1 Hans de Goede 2000-02-08 23:01:59 UTC
Created attachment 103 [details]
patch replacing the fpregset patch, fixing the described problems

Comment 2 Hans de Goede 2000-02-09 08:39:59 UTC
Already fixed in rawhide after the maillinglist discussion, closing this one.

Comment 3 openshift-github-bot 2016-12-02 18:11:01 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/964762894db8c9cc9e4d94856f4e1c31b08d62ea
Merge pull request #918 from sg00dwin/pod-donut-hover-issue9253

Merged by openshift-bot


Note You need to log in before you can comment on or make changes to this bug.