Bug 925918 - texinfo 5.1 needs perl(Carp)
Summary: texinfo 5.1 needs perl(Carp)
Keywords:
Status: CLOSED DUPLICATE of bug 924938
Alias: None
Product: Fedora
Classification: Fedora
Component: texinfo
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Vitezslav Crhonek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-23 01:15 UTC by Jerry James
Modified: 2013-03-23 02:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-23 02:28:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Jerry James 2013-03-23 01:15:08 UTC
Description of problem:
I just had a build of gcl fail like this:

make[1]: Entering directory `/builddir/build/BUILD/gcl-2.6.8/info'
makeinfo gcl-tk.texi
Can't locate Carp.pm in @INC (@INC contains: /usr/share/texinfo/lib/Unicode-EastAsianWidth/lib /usr/share/texinfo /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /usr/share/texinfo/Texinfo/Common.pm line 35.
BEGIN failed--compilation aborted at /usr/share/texinfo/Texinfo/Common.pm line 35.
Compilation failed in require at /usr/share/texinfo/Texinfo/Convert/Texinfo.pm line 27.
BEGIN failed--compilation aborted at /usr/share/texinfo/Texinfo/Convert/Texinfo.pm line 27.
Compilation failed in require at /usr/bin/makeinfo line 100.
BEGIN failed--compilation aborted at /usr/bin/makeinfo line 100.

Apparently makeinfo needs perl(Carp), but the texinfo package does not require it.

Version-Release number of selected component (if applicable):
texinfo-5.1-1.fc20.i686

How reproducible:
Always

Steps to Reproduce:
1. Attempt to build the gcl info documention
2.
3.
  
Actual results:
The build fails

Expected results:
The build succeeds

Additional info:

Comment 1 Jerry James 2013-03-23 02:28:25 UTC
Nope, sorry, this is a perl bug.

*** This bug has been marked as a duplicate of bug 924938 ***


Note You need to log in before you can comment on or make changes to this bug.