Bug 925969 - false Provides: perl(Carp)
Summary: false Provides: perl(Carp)
Keywords:
Status: CLOSED DUPLICATE of bug 924938
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Dan Mashal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-23 02:05 UTC by nucleo
Modified: 2013-03-23 06:28 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-23 06:28:28 UTC
Type: Bug


Attachments (Terms of Use)

Description nucleo 2013-03-23 02:05:34 UTC
Description of problem:
Running 'autoreconf -i -f' failed with error:

Can't locate Carp.pm in @INC (@INC contains: /usr/share/autoconf /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/autoconf/Autom4te/Channels.pm line 72.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/Channels.pm line 72.
Compilation failed in require at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
Compilation failed in require at /usr/bin/autoreconf line 39.
BEGIN failed--compilation aborted at /usr/bin/autoreconf line 39.


Version-Release number of selected component (if applicable):
autoconf 2.69-10.fc19

Comment 2 nucleo 2013-03-23 02:28:37 UTC
Adding BuildRequires: perl(Carp) don't installs perl-Carp, only explicit BuildRequires: perl-Carp installs it.

Comment 3 Kevin Kofler 2013-03-23 02:51:53 UTC
perl claims to Provide perl(Carp):
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3851739
but does not seem to actually provide it.

Comment 4 Remi Collet 2013-03-23 06:28:28 UTC

*** This bug has been marked as a duplicate of bug 924938 ***


Note You need to log in before you can comment on or make changes to this bug.