Bug 926001 - documents saved over gvfs are NOT SAVED!!!
Summary: documents saved over gvfs are NOT SAVED!!!
Status: CLOSED DUPLICATE of bug 895690
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Stephan Bergmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-23 06:34 UTC by Trever Adams
Modified: 2013-03-25 13:26 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-03-25 13:26:20 UTC


Attachments (Terms of Use)

Description Trever Adams 2013-03-23 06:34:37 UTC
Description of problem:
If you load a document from gvfs mounts, they will load. Edit them and they do NOT get saved back to the document and you get NO warning about it.

Version-Release number of selected component (if applicable):
gvfs-1.14.2-3.fc18.x86_64
gvfs-smb-1.14.2-3.fc18.x86_64
libreoffice-writer-3.6.5.2-6.fc18.x86_64

How reproducible:
Every stupid time

Steps to Reproduce:
1. Connect to an SMB server share via the gnome (gvfs?) facilities
2. Open a file from said share
3. Edit file
4. Save
5. Reload file
6. Be totally pissed off that months of work haven't been saved
 
Actual results:
Totally unacceptable. No warnings. No errors.

Yes, this is F/OSS, but this is a huge regression and makes NO sense!

Comment 1 Trever Adams 2013-03-25 08:06:42 UTC
I am not yet certain of this, but it appears that either /etc/cron.daily/prelink running fix this or kernel-3.8.4-202.fc18.x86_64 and associated and/or 1:libreoffice-writer-3.6.5.2-8.fc18.x86_64.

I will do further testing.

Comment 2 Stephan Bergmann 2013-03-25 08:45:49 UTC
libreoffice-3.6.5.2-8.fc18 contains a fix for bug 895690, of which this is a duplicate, except for the odd thing that you get no warning about the file not being saved.

Comment 3 Trever Adams 2013-03-25 09:06:35 UTC
I do on one system. But not on another. Hence the extreme frustration on the one where no warning or error is given. Thank you for fixing this. If you truly believe I duplicated, please feel free to close. Thank you again!

Comment 4 Stephan Bergmann 2013-03-25 13:26:20 UTC
With the fix for bug 895690 locally reverted (and a local fix of gvfs bug 922181, so that loading files from GVFS works in LibreOffice on x86_64), calling

  soffice sftp://.../.../test.odt

to open an existing file, changing it, "File - Save" leads to an error dialog here, "Error saving the document test: The object cannot be accessed due to insufficient user rights."

So I'm closing as duplicate for now.  Feel free to reopen if you have any information what to do differently than the above to cause LibreOffice to fail saving but /not/ show an error dialog.

*** This bug has been marked as a duplicate of bug 895690 ***


Note You need to log in before you can comment on or make changes to this bug.