Bug 926463 - ruby: Does not support aarch64 in f19 and rawhide
ruby: Does not support aarch64 in f19 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2013-03-23 12:14 EDT by Dennis Gilmore
Modified: 2013-05-29 23:37 EDT (History)
7 users (show)

See Also:
Fixed In Version: ruby-2.0.0.195-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 23:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-03-23 12:14:46 EDT
Support for the ARM 64 bit CPU architecture (aarch64) was introduced in 
autoconf 2.69.  ruby appears to use an earlier version of 
autoconf, preventing its being built.  This can be fixed in of three ways (In order of preference):

1. Work with upstream to migrate the package to autoconf 2.69.

2. Rerun autoconf or autoreconf in %prep or %build prior to running 
configure.

3. Apply the patch at http://ausil.fedorapeople.org/aarch64/ruby/ruby-aarch64.patch
which updates config.guess and config.sub to recognize aarch64.
Comment 1 Vít Ondruch 2013-05-21 04:44:27 EDT
This seems to be relevant upstream bug: http://bugs.ruby-lang.org/issues/8331
Comment 2 Fedora Update System 2013-05-21 13:17:32 EDT
Package ruby-2.0.0.195-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ruby-2.0.0.195-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8738/ruby-2.0.0.195-8.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-05-29 23:37:07 EDT
ruby-2.0.0.195-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.