Bug 926759 - xchm: Does not support aarch64 in f19 and rawhide
Summary: xchm: Does not support aarch64 in f19 and rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xchm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: manuel wolfshant
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2013-03-23 16:34 UTC by Dennis Gilmore
Modified: 2013-04-16 00:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-15 17:55:09 UTC


Attachments (Terms of Use)

Description Dennis Gilmore 2013-03-23 16:34:16 UTC
Support for the ARM 64 bit CPU architecture (aarch64) was introduced in 
autoconf 2.69.  xchm appears to use an earlier version of 
autoconf, preventing its being built.  This can be fixed in of three ways (In order of preference):

1. Work with upstream to migrate the package to autoconf 2.69.

2. Rerun autoconf or autoreconf in %prep or %build prior to running 
configure.

3. Apply the patch at http://ausil.fedorapeople.org/aarch64/xchm/xchm-aarch64.patch
which updates config.guess and config.sub to recognize aarch64.

Comment 1 Fedora Update System 2013-03-23 22:23:22 UTC
xchm-1.22-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/xchm-1.22-1.el6

Comment 2 Fedora Update System 2013-03-23 22:23:33 UTC
xchm-1.22-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xchm-1.22-1.fc17

Comment 3 Fedora Update System 2013-03-23 22:23:43 UTC
xchm-1.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xchm-1.22-1.fc18

Comment 4 Fedora Update System 2013-03-23 22:24:01 UTC
xchm-1.22-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/xchm-1.22-1.el5

Comment 5 Fedora Update System 2013-03-24 17:59:21 UTC
Package xchm-1.22-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing xchm-1.22-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-0786/xchm-1.22-1.el5
then log in and leave karma (feedback).

Comment 6 Dennis Gilmore 2013-03-26 13:43:36 UTC
please only do builds for this fix for Fedora 19 and rawhide, no where else. it is a serious waster of users time and resources, it also creates unneeded updates

Comment 7 manuel wolfshant 2013-03-26 14:09:42 UTC
I did not build anything useless. By mere coincidence this package has been recently upgraded upstream.

Comment 8 Fedora Update System 2013-04-15 17:55:11 UTC
xchm-1.22-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-04-15 17:55:43 UTC
xchm-1.22-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-04-16 00:10:58 UTC
xchm-1.22-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-04-16 00:13:50 UTC
xchm-1.22-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.