Bug 926913 - rescue mode fails with traceback
Summary: rescue mode fails with traceback
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F19Alpha, F19AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2013-03-24 02:17 UTC by Andre Robatino
Modified: 2013-04-09 03:40 UTC (History)
6 users (show)

Fixed In Version: anaconda-19.15-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-09 03:40:35 UTC
Type: Bug


Attachments (Terms of Use)
rescue mode traceback, 19 Alpha TC1 i386 DVD (13.54 KB, image/png)
2013-03-24 02:17 UTC, Andre Robatino
no flags Details
rescue mode traceback, 19 Alpha TC1 x86_64 DVD (13.57 KB, image/png)
2013-03-24 02:18 UTC, Andre Robatino
no flags Details

Description Andre Robatino 2013-03-24 02:17:33 UTC
Created attachment 715376 [details]
rescue mode traceback, 19 Alpha TC1 i386 DVD

Description of problem:
Upon starting rescue mode from the 19 Alpha TC1 DVD (either i386 or x86_64), there is a traceback. Screenshots attached.

Version-Release number of selected component (if applicable):
19.12 (from 19 Alpha TC1)

How reproducible:
always

Comment 1 Andre Robatino 2013-03-24 02:18:23 UTC
Created attachment 715377 [details]
rescue mode traceback, 19 Alpha TC1 x86_64 DVD

Comment 2 Andre Robatino 2013-03-24 02:19:37 UTC
Proposing as Alpha Blocker according to https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Rescue_mode : "The rescue mode of the installer must start successfully and be able to detect and mount an existing default installation."

Comment 3 Vratislav Podzimek 2013-03-26 14:23:29 UTC
Patch posted to anaconda-patches.

Comment 4 Adam Williamson 2013-03-27 16:17:57 UTC
Discussed at 2013-03-27 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-03-27/f19alpha-blocker-review-3.2013-03-27-16.01.log.txt . Accepted as a blocker per criterion cited in comment #2.

Comment 5 Adam Williamson 2013-03-28 20:18:39 UTC
Can someone review Vratislav's patch and get it in the next anaconda build? It's been on the list since Tuesday. Be good to fix as many blockers as possible for the next build (and make sure there are no others behind them). Thanks!

Comment 6 Jens Petersen 2013-03-29 09:25:53 UTC
(I see the same rescue backtrace with Alpha TC3 netinst.iso (anaconda-19.14))

Comment 7 Fedora Update System 2013-04-03 00:08:24 UTC
anaconda-19.15-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.15-1.fc19

Comment 8 Fedora Update System 2013-04-03 16:09:22 UTC
Package anaconda-19.15-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.15-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4754/anaconda-19.15-1.fc19
then log in and leave karma (feedback).

Comment 9 Andre Robatino 2013-04-04 07:54:09 UTC
Appears fixed in 19 Alpha TC4.

Comment 10 Adam Williamson 2013-04-04 20:47:39 UTC
Thanks, please leave karma on the anaconda build.

Comment 11 Fedora Update System 2013-04-05 00:51:43 UTC
anaconda-19.16-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.16-2.fc19

Comment 12 Fedora Update System 2013-04-09 03:40:39 UTC
anaconda-19.16-2.fc19, python-meh-0.22-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.