Bug 926954 - multicast snooping blocks multicast traffic on virtual hosts
Summary: multicast snooping blocks multicast traffic on virtual hosts
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.3
Assignee: psebek
QA Contact: Haim
URL:
Whiteboard: network
Keywords: Reopened
Depends On: 880035
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-24 12:37 UTC by W. de Heiden
Modified: 2015-12-02 13:34 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-07-09 11:27:56 UTC


Attachments (Terms of Use)

Description W. de Heiden 2013-03-24 12:37:21 UTC
Description of problem:
Mutlicast between virtual hosts gets dropped after a short period

Version-Release number of selected component (if applicable):
ovirt-node-iso-2.6.1-20120228.fc18

How reproducible:
Instal omping on both virtual hosts. A low number of ping wil turn out OK, but giving a higher number, the multicast packet loss gets huge:

omping <remote ip> local ip> -c500  (on both hosts)

192.168.1.211 :   unicast, xmt/rcv/%loss = 500/500/0%, min/avg/max/std-dev = 0.330/0.610/0.789/0.064
192.168.1.211 : multicast, xmt/rcv/%loss = 500/268/46%, min/avg/max/std-dev = 0.416/0.635/0.921/0.066

After turning off "multicast snooping", the packet loss will disappear:

echo 0 > /sys/class/net/ovirtmgmt/bridge/multicast_snooping

omping <remote ip> local ip> -c500
192.168.1.212 :   unicast, xmt/rcv/%loss = 500/500/0%, min/avg/max/std-dev = 0.353/0.623/0.944/0.075
192.168.1.212 : multicast, xmt/rcv/%loss = 500/500/0%, min/avg/max/std-dev = 0.356/0.642/0.964/0.078 

Steps to Reproduce:
1. install virt-node-iso-2.6.1-20120228
2. install 2 virtual (fedora) host and omping
3. start multicast test between virtual host using omping
  
Actual results:
Huge packet loss after apr. 200 ping.

Expected results:
0% packet loss

Additional info:

Comment 1 Dan Kenigsberg 2013-03-24 13:02:38 UTC
I've changed the component as vdsm is responsible to setting up ovirt's bridges. There's a twin bug 902922 for libvirt.

Comment 2 psebek 2013-04-30 09:08:40 UTC
This bug is waiting for the patch from https://bugzilla.redhat.com/show_bug.cgi?id=880035#c26 to get in next release.

Comment 3 psebek 2013-07-09 11:27:56 UTC
Closed because problem in 880035 was succesfully solved.


Note You need to log in before you can comment on or make changes to this bug.