Bug 927014 - perl-4:5.16.3-265.fc20.x86_64 wrongly Provides perl(Carp)
Summary: perl-4:5.16.3-265.fc20.x86_64 wrongly Provides perl(Carp)
Keywords:
Status: CLOSED DUPLICATE of bug 924938
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-24 20:12 UTC by Hans de Goede
Modified: 2013-03-24 20:34 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-24 20:34:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Hans de Goede 2013-03-24 20:12:31 UTC
[hans@shalem master]$ sudo repoquery --disablerepo=* --enablerepo=rawhide --whatprovides 'perl(Carp)'
perl-Carp-0:1.26-241.fc19.noarch
perl-4:5.16.3-265.fc20.x86_64
[hans@shalem master]$

But just having perl installed is not enough to make perl-modules which actually require Carp to work, this
results for example in build failures of packages using autoreconf, ie:
http://koji.fedoraproject.org/koji/getfile?taskID=5166523&name=build.log

+ autoreconf -i -f
Can't locate Carp.pm in @INC (@INC contains: /usr/share/autoconf /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/autoconf/Autom4te/Channels.pm line 72.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/Channels.pm line 72.
Compilation failed in require at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
Compilation failed in require at /usr/bin/autoreconf line 39.
BEGIN failed--compilation aborted at /usr/bin/autoreconf line 39.
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.jwM5Va (%prep)

Whereas having perl-Carp installed (by adding perl-Carl to the BuildRequires as a workaround), fixes this.

Note this may be related to the perl(Carp) Requires also vanishing from some packages, see bug 927010

Comment 1 Paul Howarth 2013-03-24 20:34:32 UTC

*** This bug has been marked as a duplicate of bug 924938 ***


Note You need to log in before you can comment on or make changes to this bug.