Bug 927298 - constant Puppet::Type::Package not defined
constant Puppet::Type::Package not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: puppet (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
: 949509 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-25 11:27 EDT by Marcus Moeller
Modified: 2013-04-21 00:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-21 00:59:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2013-03-25 11:27:55 EDT
Description of problem:
On a current F19 branch installation, I am trying to run puppet against manifests that worked without any problems on F18.

Error: Could not autoload puppet/type/package: constant Puppet::Type::Package not defined

Version-Release number of selected component (if applicable):
puppet-3.1.1-1.fc19.noarch
ruby-2.0.0.0-6.fc19.x86_64

How reproducible:
Define package installation in a manifest and try to run this on a current F19 branch installation with the above versions of puppet and ruby

Actual results:
Packages are not installed as puppet fails

Expected results:
Packages should be installed as listed in the relevant manifests

Additional info:
Maybe it's related to the ruby version which also has been upgraded
Comment 1 Sandro Mathys 2013-04-02 06:34:50 EDT
Hit the same error with the File (and probably any other built-in) type.

$ echo 'file { "/tmp/asdasdas":}' | puppet apply
Error: Could not autoload puppet/type/file: constant Puppet::Type::File not defined
Error: Could not autoload puppet/type/file: constant Puppet::Type::File not defined on node localhost.local.lan
Error: Could not autoload puppet/type/file: constant Puppet::Type::File not defined on node localhost.local.lan
Comment 2 Pádraig Brady 2013-04-08 06:31:32 EDT
*** Bug 949509 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-04-16 15:29:11 EDT
puppet-3.1.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/puppet-3.1.1-3.fc19
Comment 4 Fedora Update System 2013-04-17 12:26:59 EDT
Package puppet-3.1.1-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing puppet-3.1.1-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5890/puppet-3.1.1-3.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-04-21 00:59:03 EDT
puppet-3.1.1-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.